about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPavol Rusnak <pavol@rusnak.io>2019-09-01 13:41:28 +0200
committerPavol Rusnak <pavol@rusnak.io>2019-09-01 13:41:28 +0200
commita39eb9dda475c568f0c0f593c316bdbca2f913e2 (patch)
tree78425d38635916343921cdb6032eb98ced065398 /pkgs/development
parent83d60f72ae5a0f45da8d3bde0e3273f91dcffbf7 (diff)
downloadnixlib-a39eb9dda475c568f0c0f593c316bdbca2f913e2.tar
nixlib-a39eb9dda475c568f0c0f593c316bdbca2f913e2.tar.gz
nixlib-a39eb9dda475c568f0c0f593c316bdbca2f913e2.tar.bz2
nixlib-a39eb9dda475c568f0c0f593c316bdbca2f913e2.tar.lz
nixlib-a39eb9dda475c568f0c0f593c316bdbca2f913e2.tar.xz
nixlib-a39eb9dda475c568f0c0f593c316bdbca2f913e2.tar.zst
nixlib-a39eb9dda475c568f0c0f593c316bdbca2f913e2.zip
pythonPackages.trezor: fix typo (pyarg vs pyargs)
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/trezor/default.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/pkgs/development/python-modules/trezor/default.nix b/pkgs/development/python-modules/trezor/default.nix
index 47aa23ca1143..9b7dc424ddc1 100644
--- a/pkgs/development/python-modules/trezor/default.nix
+++ b/pkgs/development/python-modules/trezor/default.nix
@@ -26,9 +26,6 @@ buildPythonPackage rec {
 
   propagatedBuildInputs = [ typing-extensions protobuf hidapi ecdsa mnemonic requests pyblake2 click construct libusb1 rlp shamir-mnemonic ];
 
-  # build requires UTF-8 locale
-  LANG = "en_US.UTF-8";
-
   checkInputs = [
     pytest
   ];
@@ -36,7 +33,7 @@ buildPythonPackage rec {
   # disable test_tx_api.py as it requires being online
   checkPhase = ''
     runHook preCheck
-    ${python.interpreter} -m pytest --pyarg trezorlib.tests.unit_tests --ignore trezorlib/tests/unit_tests/test_tx_api.py
+    ${python.interpreter} -m pytest --pyargs trezorlib.tests.unit_tests --ignore trezorlib/tests/unit_tests/test_tx_api.py
     runHook postCheck
   '';