about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFabian Affolter <mail@fabian-affolter.ch>2024-03-28 21:46:10 +0100
committerFabian Affolter <mail@fabian-affolter.ch>2024-03-28 21:46:10 +0100
commita3615c2e41b5588c00c395c0339cd902d766c7bc (patch)
treece96d540eab1b5644d80906586070e442aaa5d10 /pkgs/development
parent64c81edb4b97a51c5bbc54c191763ac71a6517ee (diff)
downloadnixlib-a3615c2e41b5588c00c395c0339cd902d766c7bc.tar
nixlib-a3615c2e41b5588c00c395c0339cd902d766c7bc.tar.gz
nixlib-a3615c2e41b5588c00c395c0339cd902d766c7bc.tar.bz2
nixlib-a3615c2e41b5588c00c395c0339cd902d766c7bc.tar.lz
nixlib-a3615c2e41b5588c00c395c0339cd902d766c7bc.tar.xz
nixlib-a3615c2e41b5588c00c395c0339cd902d766c7bc.tar.zst
nixlib-a3615c2e41b5588c00c395c0339cd902d766c7bc.zip
python312Packages.pyinsteon: refactor
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pyinsteon/default.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/pkgs/development/python-modules/pyinsteon/default.nix b/pkgs/development/python-modules/pyinsteon/default.nix
index e2e25aa18dcd..4597e0e2dd93 100644
--- a/pkgs/development/python-modules/pyinsteon/default.nix
+++ b/pkgs/development/python-modules/pyinsteon/default.nix
@@ -1,6 +1,7 @@
 { lib
 , aiofiles
 , aiohttp
+, async-timeout
 , async-generator
 , buildPythonPackage
 , fetchFromGitHub
@@ -12,31 +13,30 @@
 , pythonOlder
 , setuptools
 , voluptuous
-, wheel
 }:
 
 buildPythonPackage rec {
   pname = "pyinsteon";
   version = "1.5.3";
-  format = "pyproject";
+  pyproject = true;
 
   disabled = pythonOlder "3.8";
 
   src = fetchFromGitHub {
-    owner = pname;
-    repo = pname;
+    owner = "pyinsteon";
+    repo = "pyinsteon";
     rev = "refs/tags/${version}";
     hash = "sha256-9d6QbekUv63sjKdK+ZogYOkGfFXVW+JB6ITHnehLwtM=";
   };
 
-  nativeBuildInputs = [
+  build-system = [
     setuptools
-    wheel
   ];
 
-  propagatedBuildInputs = [
+  dependencies = [
     aiofiles
     aiohttp
+    async-timeout
     pypubsub
     pyserial
     pyserial-asyncio
@@ -60,7 +60,7 @@ buildPythonPackage rec {
     "test_other_status"
     "test_status_command"
     "test_status_request_hub"
-    # stuck in epoll
+    # Test stuck in epoll
     "test_read_all_peek"
   ];
 
@@ -70,7 +70,6 @@ buildPythonPackage rec {
 
   meta = with lib; {
     description = "Python library to support Insteon home automation projects";
-    mainProgram = "insteon_tools";
     longDescription = ''
       This is a Python package to interface with an Insteon Modem. It has been
       tested to work with most USB or RS-232 serial based devices such as the
@@ -80,5 +79,6 @@ buildPythonPackage rec {
     changelog = "https://github.com/pyinsteon/pyinsteon/releases/tag/${version}";
     license = with licenses; [ mit ];
     maintainers = with maintainers; [ fab ];
+    mainProgram = "insteon_tools";
   };
 }