about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authoraszlig <aszlig@nix.build>2018-04-25 14:58:54 +0200
committeraszlig <aszlig@nix.build>2018-04-25 15:01:41 +0200
commita3502ba765ed5634b62d2440d342f81f68a67a8b (patch)
treefd1957fbb4bf7962c546d8870599bd0d199ad769 /pkgs/development
parentac61ae50b7b47dfae92ff921dab0774554e7df9e (diff)
downloadnixlib-a3502ba765ed5634b62d2440d342f81f68a67a8b.tar
nixlib-a3502ba765ed5634b62d2440d342f81f68a67a8b.tar.gz
nixlib-a3502ba765ed5634b62d2440d342f81f68a67a8b.tar.bz2
nixlib-a3502ba765ed5634b62d2440d342f81f68a67a8b.tar.lz
nixlib-a3502ba765ed5634b62d2440d342f81f68a67a8b.tar.xz
nixlib-a3502ba765ed5634b62d2440d342f81f68a67a8b.tar.zst
nixlib-a3502ba765ed5634b62d2440d342f81f68a67a8b.zip
gn: Add libc++ and libc++abi from third_party
On GNU/Linux the build references these files, so let's fetch them from
the Chromium repository. I haven't checked whether they are heavily
patched or whether we can use the version from LLVM, but when looking at
the changes, they do seem to divert a bit from upstream LLVM.

Signed-off-by: aszlig <aszlig@nix.build>
Cc: @matthewbauer, @stesie
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/build-managers/gn/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/pkgs/development/tools/build-managers/gn/default.nix b/pkgs/development/tools/build-managers/gn/default.nix
index a9930d258c2c..35f54369abd9 100644
--- a/pkgs/development/tools/build-managers/gn/default.nix
+++ b/pkgs/development/tools/build-managers/gn/default.nix
@@ -33,6 +33,16 @@ let
       sha256 = "1vgcg741lwz84kdy0qc5wn9dxx3j9zh6a9d185fpygdsipwikqv8";
       stripRoot = false;
     };
+    "buildtools/third_party/libc++/trunk" = fetchgit {
+      url = "https://chromium.googlesource.com/chromium/llvm-project/libcxx";
+      rev = "ece1de8658d749e19c12cacd4458cc330eca94e3";
+      sha256 = "1nlyvfkzhchwv9b18bh82jcamqv3acj26ah9ajs31f2dql05amhg";
+    };
+    "buildtools/third_party/libc++abi/trunk" = fetchgit {
+      url = "https://chromium.googlesource.com/chromium/llvm-project/libcxxabi";
+      rev = "52c7a3760aef1df328a9bc957f686410872f0dc0";
+      sha256 = "1aam539j01381q27b7xhij18pz3h0lhw08hglvqq4hgvlqx5cn2s";
+    };
   };
 
 in stdenv.mkDerivation {