about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2016-04-28 11:59:13 +0200
committerPeter Simons <simons@cryp.to>2016-04-28 12:02:08 +0200
commita2e1692730537ee5b8cbcabdd47dbc10ad2a7383 (patch)
tree9677ecde50e90ef1a40e24ef3990e26f5de45769 /pkgs/development
parent66a224c99dc1ffcb784d208a1d30f4660e3dd405 (diff)
downloadnixlib-a2e1692730537ee5b8cbcabdd47dbc10ad2a7383.tar
nixlib-a2e1692730537ee5b8cbcabdd47dbc10ad2a7383.tar.gz
nixlib-a2e1692730537ee5b8cbcabdd47dbc10ad2a7383.tar.bz2
nixlib-a2e1692730537ee5b8cbcabdd47dbc10ad2a7383.tar.lz
nixlib-a2e1692730537ee5b8cbcabdd47dbc10ad2a7383.tar.xz
nixlib-a2e1692730537ee5b8cbcabdd47dbc10ad2a7383.tar.zst
nixlib-a2e1692730537ee5b8cbcabdd47dbc10ad2a7383.zip
haskell-split: disable test suite to avoid transient build failures
We have frequent build failures of "split" because the QuickCheck testsuite
cannot generate enough conclusive test cases, i.e. in

  https://hydra.nixos.org/build/34857780/nixlog/1/raw

Cc: @byorgey
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index ecae4cb8eb61..363ddcbea886 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -1010,4 +1010,8 @@ self: super: {
   # tinc is a new build driver a la Stack that's not yet available from Hackage.
   tinc = self.callPackage ../tools/haskell/tinc {};
 
+  # Avoid transient build failures because the QuickCheck testsuite cannot
+  # generate enough conclusive test cases.
+  split = dontCheck super.split;
+
 }