about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-04-20 13:11:35 +0200
committerRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-04-20 13:11:35 +0200
commita141b15e970f4c96041f6957409b6fa84ac4ec31 (patch)
tree3559dbc40aaae32018f781e003b2a68c6ecbc472 /pkgs/development
parent610ca3b95a73393cb896e8558335dda657d75664 (diff)
downloadnixlib-a141b15e970f4c96041f6957409b6fa84ac4ec31.tar
nixlib-a141b15e970f4c96041f6957409b6fa84ac4ec31.tar.gz
nixlib-a141b15e970f4c96041f6957409b6fa84ac4ec31.tar.bz2
nixlib-a141b15e970f4c96041f6957409b6fa84ac4ec31.tar.lz
nixlib-a141b15e970f4c96041f6957409b6fa84ac4ec31.tar.xz
nixlib-a141b15e970f4c96041f6957409b6fa84ac4ec31.tar.zst
nixlib-a141b15e970f4c96041f6957409b6fa84ac4ec31.zip
python.pkgs.cherrypy: clean up checkInputs
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/cherrypy/default.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/pkgs/development/python-modules/cherrypy/default.nix b/pkgs/development/python-modules/cherrypy/default.nix
index 18c0ab826b3a..bb97a3a7e678 100644
--- a/pkgs/development/python-modules/cherrypy/default.nix
+++ b/pkgs/development/python-modules/cherrypy/default.nix
@@ -1,11 +1,10 @@
 { lib, buildPythonPackage, fetchPypi
 , cheroot, portend, routes, six
 , setuptools_scm
-, backports_unittest-mock, codecov, coverage, objgraph, pathpy, pytest, pytest-sugar, pytestcov
+, backports_unittest-mock, objgraph, pathpy, pytest, pytestcov
 }:
 
 buildPythonPackage rec {
-  name = "${pname}-${version}";
   pname = "CherryPy";
   version = "14.0.1";
 
@@ -18,7 +17,7 @@ buildPythonPackage rec {
 
   buildInputs = [ setuptools_scm ];
 
-  checkInputs = [ backports_unittest-mock codecov coverage objgraph pathpy pytest pytest-sugar pytestcov ];
+  checkInputs = [ backports_unittest-mock objgraph pathpy pytest pytestcov ];
 
   checkPhase = ''
     LANG=en_US.UTF-8 pytest