about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRyan Mulligan <ryan@ryantm.com>2019-02-24 07:12:56 -0800
committerGitHub <noreply@github.com>2019-02-24 07:12:56 -0800
commita13f0a1dcd58d34abeb41d671a78b7cb8efc70e8 (patch)
treee6c0f6e36031a8437be5e8507fa2b3f49550407d /pkgs/development
parent64eb7cb097982f2fc222f858101502150e3ffa43 (diff)
parent712f5f9dafe12227a2c867b2533b1fe6b476b082 (diff)
downloadnixlib-a13f0a1dcd58d34abeb41d671a78b7cb8efc70e8.tar
nixlib-a13f0a1dcd58d34abeb41d671a78b7cb8efc70e8.tar.gz
nixlib-a13f0a1dcd58d34abeb41d671a78b7cb8efc70e8.tar.bz2
nixlib-a13f0a1dcd58d34abeb41d671a78b7cb8efc70e8.tar.lz
nixlib-a13f0a1dcd58d34abeb41d671a78b7cb8efc70e8.tar.xz
nixlib-a13f0a1dcd58d34abeb41d671a78b7cb8efc70e8.tar.zst
nixlib-a13f0a1dcd58d34abeb41d671a78b7cb8efc70e8.zip
Merge pull request #53472 from borisbabic/feature/init-virtscreen
virtscreen: init at 0.3.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/quamash/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/quamash/default.nix b/pkgs/development/python-modules/quamash/default.nix
new file mode 100644
index 000000000000..b39e081c4712
--- /dev/null
+++ b/pkgs/development/python-modules/quamash/default.nix
@@ -0,0 +1,30 @@
+{ lib, buildPythonPackage, fetchFromGitHub, pytest, isPy3k, pyqt5, pyqt ? pyqt5 }:
+
+buildPythonPackage rec {
+  pname = "quamash";
+  version = "0.6.1";
+
+  disabled = !isPy3k;
+
+  # No tests in PyPi tarball
+  src = fetchFromGitHub {
+    owner = "harvimt";
+    repo = "quamash";
+    rev = "version-${version}";
+    sha256 = "117rp9r4lz0kfz4dmmpa35hp6nhbh6b4xq0jmgvqm68g9hwdxmqa";
+  };
+
+  propagatedBuildInputs = [ pyqt ];
+
+  checkInputs = [ pytest ];
+  checkPhase = ''
+     pytest -k 'test_qthreadexec.py' # the others cause the test execution to be aborted, I think because of asyncio
+  '';
+
+  meta = with lib; {
+    description = "Implementation of the PEP 3156 event-loop (asyncio) api using the Qt Event-Loop";
+    homepage = https://github.com/harvimt/quamash;
+    license = licenses.bsd2;
+    maintainers = with maintainers; [ borisbabic ];
+  };
+}