about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
author(cdep)illabout <cdep.illabout@gmail.com>2020-04-15 22:41:09 +0900
committerPeter Simons <simons@cryp.to>2020-04-17 20:50:48 +0200
commita0612c2a068d2fb783443a9776f476d729b89288 (patch)
tree0726f7d6615fffb933eca56ee3f6861faa396139 /pkgs/development
parent7932fb22cbf4df9d1b630e130160b3081bd5de10 (diff)
downloadnixlib-a0612c2a068d2fb783443a9776f476d729b89288.tar
nixlib-a0612c2a068d2fb783443a9776f476d729b89288.tar.gz
nixlib-a0612c2a068d2fb783443a9776f476d729b89288.tar.bz2
nixlib-a0612c2a068d2fb783443a9776f476d729b89288.tar.lz
nixlib-a0612c2a068d2fb783443a9776f476d729b89288.tar.xz
nixlib-a0612c2a068d2fb783443a9776f476d729b89288.tar.zst
nixlib-a0612c2a068d2fb783443a9776f476d729b89288.zip
spago: 0.14.0 -> 0.15.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix15
-rw-r--r--pkgs/development/tools/purescript/spago/spago.nix22
2 files changed, 15 insertions, 22 deletions
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index fb8412a6a9b9..9c85c2b0f733 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -655,22 +655,19 @@ self: super: builtins.intersectAttrs super {
 
   spago =
     let
-      # Spago needs a patch for MonadFail changes.
-      # https://github.com/purescript/spago/pull/584
-      # This can probably be removed when a version after spago-0.14.0 is released.
+      # Spago needs a small patch to work with the latest versions of rio.
+      # https://github.com/purescript/spago/pull/616
+      # This can probably be removed when a version after spago-0.15.1 is released.
       spagoWithPatches = appendPatch super.spago (pkgs.fetchpatch {
-        url = "https://github.com/purescript/spago/pull/584/commits/898a8e48665e5a73ea03525ce2c973455ab9ac52.patch";
-        sha256 = "05gs1hjlcf60cr6728rhgwwgxp3ildly14v4l2lrh6ma2fljhyjy";
+        url = "https://github.com/purescript/spago/pull/616/commits/95b5fa0f1d3bfb07972d1ef5004b8bee8a070667.patch";
+        sha256 = "0v3890lwhddfrq9mhbq92962pkxra8kwbin97wg3s0b02dk65ysc";
       });
 
       # Spago basically compiles with LTS-14, but it requires a newer version
       # of directory.  This is to work around a bug only present on windows, so
       # we can safely jailbreak spago and use the older directory package from
       # LTS-14.
-      spagoWithOverrides = doJailbreak (spagoWithPatches.override {
-        # spago requires dhall-1.29.0.
-        dhall = self.dhall_1_29_0;
-      });
+      spagoWithOverrides = doJailbreak spagoWithPatches;
 
       # This defines the version of the purescript-docs-search release we are using.
       # This is defined in the src/Spago/Prelude.hs file in the spago source.
diff --git a/pkgs/development/tools/purescript/spago/spago.nix b/pkgs/development/tools/purescript/spago/spago.nix
index adf019eef572..254a7bc97e43 100644
--- a/pkgs/development/tools/purescript/spago/spago.nix
+++ b/pkgs/development/tools/purescript/spago/spago.nix
@@ -7,15 +7,15 @@
 , prettyprinter, process, QuickCheck, retry, rio, rio-orphans, safe
 , semver-range, stdenv, stm, tar, template-haskell, temporary, text
 , time, transformers, turtle, unliftio, unordered-containers
-, vector, versions, zlib
+, vector, versions, with-utf8, zlib
 }:
 mkDerivation {
   pname = "spago";
-  version = "0.14.0";
+  version = "0.15.1";
   src = fetchgit {
     url = "https://github.com/purescript/spago.git";
-    sha256 = "12i1430prqspy73nwfxc17zf51yprhrxxcnhw4rks6jhkgwxf4a4";
-    rev = "7a99343e4876a465600eaa64b0697a9f0b2a49a9";
+    sha256 = "09ypbm03ap8xfhq803ra3cc01dxcavckn7nis6hi80dk2xxlhc3d";
+    rev = "d5d206ff0f5c686f8b609fb4bc2e866959cc0144";
     fetchSubmodules = true;
   };
   isLibrary = true;
@@ -25,17 +25,13 @@ mkDerivation {
     bytestring Cabal containers dhall directory either exceptions
     file-embed filepath foldl fsnotify github Glob http-client
     http-conduit lens-family-core megaparsec mtl network-uri
-    open-browser prettyprinter process retry rio rio-orphans safe
-    semver-range stm tar template-haskell temporary text time
-    transformers turtle unliftio unordered-containers vector versions
-    zlib
+    open-browser optparse-applicative prettyprinter process retry rio
+    rio-orphans safe semver-range stm tar template-haskell temporary
+    text time transformers turtle unliftio unordered-containers vector
+    versions with-utf8 zlib
   ];
   libraryToolDepends = [ hpack ];
-  executableHaskellDepends = [
-    aeson-pretty async-pool base bytestring containers dhall filepath
-    github lens-family-core megaparsec optparse-applicative process
-    retry stm temporary text time turtle vector
-  ];
+  executableHaskellDepends = [ base text turtle with-utf8 ];
   testHaskellDepends = [
     base containers directory extra hspec hspec-megaparsec megaparsec
     process QuickCheck temporary text turtle versions