about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2016-12-25 11:12:19 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2016-12-25 11:12:53 +0100
commit9f5e022663ebeb11b0e1300dfcc3fbd492c8e72b (patch)
tree6dfbd6410b79f60bdb951ccf00e88a2c878fa333 /pkgs/development
parentc1dd42e7d64dc86b96df4aeafbc944f322cf8121 (diff)
downloadnixlib-9f5e022663ebeb11b0e1300dfcc3fbd492c8e72b.tar
nixlib-9f5e022663ebeb11b0e1300dfcc3fbd492c8e72b.tar.gz
nixlib-9f5e022663ebeb11b0e1300dfcc3fbd492c8e72b.tar.bz2
nixlib-9f5e022663ebeb11b0e1300dfcc3fbd492c8e72b.tar.lz
nixlib-9f5e022663ebeb11b0e1300dfcc3fbd492c8e72b.tar.xz
nixlib-9f5e022663ebeb11b0e1300dfcc3fbd492c8e72b.tar.zst
nixlib-9f5e022663ebeb11b0e1300dfcc3fbd492c8e72b.zip
pythonPackages.pytest_expect: init at 1.1.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pytest-expect/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/pytest-expect/default.nix b/pkgs/development/python-modules/pytest-expect/default.nix
new file mode 100644
index 000000000000..5abfd9423ac7
--- /dev/null
+++ b/pkgs/development/python-modules/pytest-expect/default.nix
@@ -0,0 +1,31 @@
+{ buildPythonPackage
+, lib
+, fetchurl
+, pytest
+, u-msgpack-python
+, six
+}:
+
+let
+  pname = "pytest-expect";
+  version = "1.1.0";
+in buildPythonPackage rec {
+  name = "${pname}-${version}";
+
+  src = fetchurl {
+    url = "mirror://pypi/${builtins.substring 0 1 pname}/${pname}/${name}.tar.gz";
+    sha256 = "36b4462704450798197d090809a05f4e13649d9cba9acdc557ce9517da1fd847";
+  };
+
+  buildInputs = [ pytest ];
+  propagatedBuildInputs = [ u-msgpack-python six ];
+
+  # Tests in neither the archive nor the repo
+  doCheck = false;
+
+  meta = {
+    description = "py.test plugin to store test expectations and mark tests based on them";
+    homepage = https://github.com/gsnedders/pytest-expect;
+    license = lib.licenses.mit;
+  };
+}
\ No newline at end of file