about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2019-06-13 06:40:48 +0000
committerVincent Laporte <vbgl@users.noreply.github.com>2019-06-20 07:29:20 +0000
commit99fec0eeb349a5f8b6c634c73455d30674b4db73 (patch)
treeac45afad1cdde327786fe21aa39d398acc6f627f /pkgs/development
parent3e9f9a64d174954b8d228784524c5f96f7fba2da (diff)
downloadnixlib-99fec0eeb349a5f8b6c634c73455d30674b4db73.tar
nixlib-99fec0eeb349a5f8b6c634c73455d30674b4db73.tar.gz
nixlib-99fec0eeb349a5f8b6c634c73455d30674b4db73.tar.bz2
nixlib-99fec0eeb349a5f8b6c634c73455d30674b4db73.tar.lz
nixlib-99fec0eeb349a5f8b6c634c73455d30674b4db73.tar.xz
nixlib-99fec0eeb349a5f8b6c634c73455d30674b4db73.tar.zst
nixlib-99fec0eeb349a5f8b6c634c73455d30674b4db73.zip
ocamlPackages.bistro: init at 0.4.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/bistro/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/development/ocaml-modules/bistro/default.nix b/pkgs/development/ocaml-modules/bistro/default.nix
new file mode 100644
index 000000000000..b3dddec511c4
--- /dev/null
+++ b/pkgs/development/ocaml-modules/bistro/default.nix
@@ -0,0 +1,27 @@
+{ lib, fetchFromGitHub, buildDunePackage
+, core, lwt ? ocaml_lwt, ocaml_lwt, ocamlgraph, rresult, tyxml
+}:
+
+buildDunePackage rec {
+  pname = "bistro";
+  version = "0.4.0";
+  src = fetchFromGitHub {
+    owner = "pveber";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "0bxnggm4nkyl2iqwj4f5afw8lj5miq2rqsc9qfrlmg4g4rr3zh1c";
+  };
+
+  buildInputs = [ lwt ocamlgraph rresult tyxml ];
+
+  propagatedBuildInputs = [ core ];
+
+  minimumOCamlVersion = "4.04";
+
+  meta = {
+    inherit (src.meta) homepage;
+    description = "Build and execute typed scientific workflows";
+    maintainers = [ lib.maintainers.vbgl ];
+    license = lib.licenses.gpl2;
+  };
+}