about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2020-02-18 09:40:38 +0100
committerMaximilian Bosch <maximilian@mbosch.me>2020-02-18 13:40:16 +0100
commit9704297c5d3e319fc09ec6e609b15601ef1b694f (patch)
treee3281ae367b007d6328e09181ad7addfba4b4fb7 /pkgs/development
parente2c3b16f9914f0308d870efa70c3a391f51d1c91 (diff)
downloadnixlib-9704297c5d3e319fc09ec6e609b15601ef1b694f.tar
nixlib-9704297c5d3e319fc09ec6e609b15601ef1b694f.tar.gz
nixlib-9704297c5d3e319fc09ec6e609b15601ef1b694f.tar.bz2
nixlib-9704297c5d3e319fc09ec6e609b15601ef1b694f.tar.lz
nixlib-9704297c5d3e319fc09ec6e609b15601ef1b694f.tar.xz
nixlib-9704297c5d3e319fc09ec6e609b15601ef1b694f.tar.zst
nixlib-9704297c5d3e319fc09ec6e609b15601ef1b694f.zip
date: init at 2020-01-24
Needed for waybar-0.9.1.
Closes #78458

Co-authored-by: Cole Mickens <cole.mickens@gmail.com>
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/howard-hinnant-date/default.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/pkgs/development/libraries/howard-hinnant-date/default.nix b/pkgs/development/libraries/howard-hinnant-date/default.nix
new file mode 100644
index 000000000000..30e5c92b8f09
--- /dev/null
+++ b/pkgs/development/libraries/howard-hinnant-date/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, fetchFromGitHub, cmake, curl, fetchpatch }:
+
+stdenv.mkDerivation rec {
+  pname = "howard-hinnant-date-unstable";
+  version = "2020-01-24";
+
+  src = fetchFromGitHub {
+    owner = "HowardHinnant";
+    repo = "date";
+    rev = "9a0ee2542848ab8625984fc8cdbfb9b5414c0082";
+    sha256 = "0yxsn0hj22n61bjywysxqgfv7hj5xvsl6isma95fl8xrimpny083";
+  };
+
+  patches = [
+    (fetchpatch {
+      url = "https://github.com/HowardHinnant/date/commit/e56b2dce7e89a92e1b9b35caa13b3e938c4cedea.patch";
+      sha256 = "0m3qbhq7kmm9qa3jm6d2px7c1dxdj5k9lffgdvqnrwmhxwj1p9n2";
+    })
+  ];
+
+  nativeBuildInputs = [ cmake ];
+  buildInputs = [ curl ];
+
+  cmakeFlags = [
+    "-DBUILD_TZ_LIB=true"
+    "-DBUILD_SHARED_LIBS=true"
+  ];
+
+  outputs = [ "out" "dev" ];
+
+  meta = with stdenv.lib; {
+    license = licenses.mit;
+    description = "A date and time library based on the C++11/14/17 <chrono> header";
+    homepage = "https://github.com/HowardHinnant/date";
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ ma27 ];
+  };
+}