about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2017-05-05 21:10:17 +0200
committerGitHub <noreply@github.com>2017-05-05 21:10:17 +0200
commit9652e3e8f2b01f79bd53dc41d060d3dff8a7deca (patch)
treee67214cbc53cb06400f7a5d3506d1cc2b005765d /pkgs/development
parentef1149e8291a196d42ddb099f48952b241f936cd (diff)
parent5762985302e4947529ec09ad185f9403f8f90a44 (diff)
downloadnixlib-9652e3e8f2b01f79bd53dc41d060d3dff8a7deca.tar
nixlib-9652e3e8f2b01f79bd53dc41d060d3dff8a7deca.tar.gz
nixlib-9652e3e8f2b01f79bd53dc41d060d3dff8a7deca.tar.bz2
nixlib-9652e3e8f2b01f79bd53dc41d060d3dff8a7deca.tar.lz
nixlib-9652e3e8f2b01f79bd53dc41d060d3dff8a7deca.tar.xz
nixlib-9652e3e8f2b01f79bd53dc41d060d3dff8a7deca.tar.zst
nixlib-9652e3e8f2b01f79bd53dc41d060d3dff8a7deca.zip
Merge pull request #25404 from vrthra/csvkit
csvkit: 0.9.1 -> 1.0.2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/aenum/default.nix15
-rw-r--r--pkgs/development/python-modules/agate-dbf/default.nix21
-rw-r--r--pkgs/development/python-modules/agate-excel/default.nix22
-rw-r--r--pkgs/development/python-modules/agate-sql/default.nix21
-rw-r--r--pkgs/development/python-modules/agate/default.nix27
-rw-r--r--pkgs/development/python-modules/csvkit/default.nix28
-rw-r--r--pkgs/development/python-modules/dbf/default.nix25
-rw-r--r--pkgs/development/python-modules/dbfread/default.nix19
-rw-r--r--pkgs/development/python-modules/python-slugify/default.nix24
-rw-r--r--pkgs/development/python-modules/pytimeparse/default.nix21
10 files changed, 219 insertions, 4 deletions
diff --git a/pkgs/development/python-modules/aenum/default.nix b/pkgs/development/python-modules/aenum/default.nix
index 1233b94dccdf..9d6fe94a262b 100644
--- a/pkgs/development/python-modules/aenum/default.nix
+++ b/pkgs/development/python-modules/aenum/default.nix
@@ -1,18 +1,25 @@
-{ stdenv, fetchPypi, buildPythonPackage }:
+{ stdenv, fetchPypi, buildPythonPackage, isPy3k }:
 
 buildPythonPackage rec {
   pname = "aenum";
-  version = "1.4.7";
+  version = "2.0.6";
   name = "${pname}-${version}";
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "1bvn2k53nz99fiwql5fkl0fh7xjw8ama9qzdjp36609mpk05ikl8";
+    sha256 = "0rlhb5wzlyyz0l44r2jxn3m0nh51ifih97dk2y7zfs1m299gwcv6";
   };
 
+  doCheck = !isPy3k;
+  # The following tests fail (only in python3
+  # test_convert (aenum.test.TestIntEnumConvert)
+  # test_convert_value_lookup_priority (aenum.test.TestIntEnumConvert)
+  # test_convert (aenum.test.TestIntEnumConvert)
+  # test_convert_value_lookup_priority (aenum.test.TestIntEnumConvert)
+
   meta = {
     description = "Advanced Enumerations (compatible with Python's stdlib Enum), NamedTuples, and NamedConstants";
-    maintainer = with stdenv.lib.maintainers; [ vrthra ];
+    maintainers = with stdenv.lib.maintainers; [ vrthra ];
     license = with stdenv.lib.licenses; [ bsd3 ];
     homepage = https://bitbucket.org/stoneleaf/aenum;
   };
diff --git a/pkgs/development/python-modules/agate-dbf/default.nix b/pkgs/development/python-modules/agate-dbf/default.nix
new file mode 100644
index 000000000000..11409a11778f
--- /dev/null
+++ b/pkgs/development/python-modules/agate-dbf/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchPypi, buildPythonPackage, agate, dbf, dbfread }:
+
+buildPythonPackage rec {
+    name = "${pname}-${version}";
+    pname = "agate-dbf";
+    version = "0.2.0";
+
+    propagatedBuildInputs = [ agate dbf dbfread ];
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "0pkk6m873xpqj77ja6ylmg8v41abpn4bvsqw6mh2hjyd0snw2rh6";
+    };
+
+    meta = with stdenv.lib; {
+      description = "Adds read support for dbf files to agate";
+      homepage    = https://github.com/wireservice/agate-dbf;
+      license     = with licenses; [ mit ];
+      maintainers = with maintainers; [ vrthra ];
+    };
+}
diff --git a/pkgs/development/python-modules/agate-excel/default.nix b/pkgs/development/python-modules/agate-excel/default.nix
new file mode 100644
index 000000000000..cb0113c22b3d
--- /dev/null
+++ b/pkgs/development/python-modules/agate-excel/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, fetchPypi, buildPythonPackage, agate, openpyxl, xlrd }:
+
+buildPythonPackage rec {
+    name = "${pname}-${version}";
+    pname = "agate-excel";
+    version = "0.2.1";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "1d28s01a0a8n8rdrd78w88cqgl3lawzy38h9afwm0iks618i0qn7";
+    };
+
+    propagatedBuildInputs = [ agate openpyxl xlrd ];
+
+    meta = with stdenv.lib; {
+      description = "Adds read support for excel files to agate";
+      homepage    = "https://github.com/wireservice/agate-excel";
+      license     = licenses.mit;
+      maintainers = with maintainers; [ vrthra ];
+    };
+
+}
diff --git a/pkgs/development/python-modules/agate-sql/default.nix b/pkgs/development/python-modules/agate-sql/default.nix
new file mode 100644
index 000000000000..0167b40ea43f
--- /dev/null
+++ b/pkgs/development/python-modules/agate-sql/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchPypi, buildPythonPackage, agate, sqlalchemy }:
+
+buildPythonPackage rec {
+    name = "${pname}-${version}";
+    pname = "agate-sql";
+    version = "0.5.2";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "0qlfwql6fnbs0r1rj7nxv4n5scad53b8dlh4qv6gyklvdk3wwn14";
+    };
+
+    propagatedBuildInputs = [ agate sqlalchemy ];
+
+    meta = with stdenv.lib; {
+      description = "Adds SQL read/write support to agate.";
+      homepage    = https://github.com/wireservice/agate-sql;
+      license     = with licenses; [ mit ];
+      maintainers = with maintainers; [ vrthra ];
+    };
+}
diff --git a/pkgs/development/python-modules/agate/default.nix b/pkgs/development/python-modules/agate/default.nix
new file mode 100644
index 000000000000..3ff097a78cf3
--- /dev/null
+++ b/pkgs/development/python-modules/agate/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchPypi, buildPythonPackage, isPy3k,
+  discid, six, parsedatetime, isodate, Babel, pytimeparse,
+  leather, python-slugify }:
+
+buildPythonPackage rec {
+    name = "${pname}-${version}";
+    pname = "agate";
+    version = "1.6.0";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "02pb5jjvzjqfpsa7q12afbk9nqj06xdpw1s7qa6a1bnalikfniqm";
+    };
+
+    propagatedBuildInputs = [ discid six parsedatetime
+         isodate Babel pytimeparse leather python-slugify ];
+
+    doCheck = !isPy3k;
+    # (only) on python3 unittest loader (loadTestsFromModule) fails
+
+    meta = with stdenv.lib; {
+      description = "A Python data analysis library that is optimized for humans instead of machines";
+      homepage    = https://github.com/wireservice/agate;
+      license     = with licenses; [ mit ];
+      maintainers = with maintainers; [ vrthra ];
+    };
+}
diff --git a/pkgs/development/python-modules/csvkit/default.nix b/pkgs/development/python-modules/csvkit/default.nix
new file mode 100644
index 000000000000..bfabf4376e7a
--- /dev/null
+++ b/pkgs/development/python-modules/csvkit/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchPypi, buildPythonPackage,
+  dateutil, dbf, xlrd, sqlalchemy, openpyxl,
+ agate-excel, agate-dbf, agate-sql, isPy3k }:
+
+buildPythonPackage rec {
+    name = "${pname}-${version}";
+    pname = "csvkit";
+    version = "1.0.2";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "05vfsba9nwh4islszgs18rq8sjkpzqni0cdwvvkw7pi0r63pz2as";
+    };
+
+    propagatedBuildInputs = [ dateutil dbf xlrd sqlalchemy openpyxl
+      agate-excel agate-dbf agate-sql ];
+
+    doCheck = !isPy3k;
+    # (only) python 3 we had 9 failures and 57 errors out of a much larger
+    # number of tests.
+
+    meta = with stdenv.lib; {
+      description = "A library of utilities for working with CSV, the king of tabular file formats";
+      maintainers = with maintainers; [ vrthra ];
+      license = with licenses; [ mit ];
+      homepage = https://github.com/wireservice/csvkit;
+    };
+}
diff --git a/pkgs/development/python-modules/dbf/default.nix b/pkgs/development/python-modules/dbf/default.nix
new file mode 100644
index 000000000000..2343ea2918b1
--- /dev/null
+++ b/pkgs/development/python-modules/dbf/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchPypi, buildPythonPackage, aenum, isPy3k }:
+
+buildPythonPackage rec {
+    pname = "dbf";
+    version = "0.96.8";
+    name = "${pname}-${version}";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "1z8n7s4cka6x9ybh4qpfhj51v2qrk38h2f06npizzhm0hmn6r3v1";
+    };
+
+    propagatedBuildInputs = [ aenum ];
+
+    doCheck = !isPy3k;
+    # tests are not yet ported.
+    # https://groups.google.com/forum/#!topic/python-dbase/96rx2xmCG4w
+
+    meta = with stdenv.lib; {
+      description = "Pure python package for reading/writing dBase, FoxPro, and Visual FoxPro .dbf files";
+      homepage    = "https://pypi.python.org/pypi/dbf";
+      license     = licenses.bsd2;
+      maintainers = with maintainers; [ vrthra ];
+    };
+}
diff --git a/pkgs/development/python-modules/dbfread/default.nix b/pkgs/development/python-modules/dbfread/default.nix
new file mode 100644
index 000000000000..6bbc4775605b
--- /dev/null
+++ b/pkgs/development/python-modules/dbfread/default.nix
@@ -0,0 +1,19 @@
+{ stdenv, fetchPypi, buildPythonPackage }:
+
+buildPythonPackage rec {
+    name = "${pname}-${version}";
+    pname = "dbfread";
+    version = "2.0.5";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "0r5axq9ax0czyapm7b69krcv22r1nyb4vci7c5x8mx8pq1axim93";
+    };
+
+    meta = with stdenv.lib; {
+      description = "Read DBF Files with Python";
+      homepage    = http://dbfread.readthedocs.org/;
+      license     = with licenses; [ mit ];
+      maintainers = with maintainers; [ vrthra ];
+    };
+}
diff --git a/pkgs/development/python-modules/python-slugify/default.nix b/pkgs/development/python-modules/python-slugify/default.nix
new file mode 100644
index 000000000000..03c37f7a6c45
--- /dev/null
+++ b/pkgs/development/python-modules/python-slugify/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchPypi, buildPythonPackage, unidecode, regex, isPy3k }:
+
+buildPythonPackage rec {
+    name = "${pname}-${version}";
+    pname = "python-slugify";
+    version = "1.2.4";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "097qllxys22kghcv2a5jcc1zdlr9zzqayvk6ywavsv8wgbgqb8sp";
+    };
+    doCheck = !isPy3k;
+    # (only) on python3 unittest loader (loadTestsFromModule) fails
+
+    propagatedBuildInputs = [ unidecode regex ];
+
+    meta = with stdenv.lib; {
+      homepage = https://github.com/un33k/python-slugify;
+      description = "A Python Slugify application that handles Unicode";
+      license = licenses.mit;
+      platforms = platforms.all;
+      maintainers = with maintainers; [ vrthra ];
+    };
+}
diff --git a/pkgs/development/python-modules/pytimeparse/default.nix b/pkgs/development/python-modules/pytimeparse/default.nix
new file mode 100644
index 000000000000..ce5ff0586649
--- /dev/null
+++ b/pkgs/development/python-modules/pytimeparse/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchPypi, buildPythonPackage, nose }:
+
+buildPythonPackage rec {
+    pname = "pytimeparse";
+    version = "1.1.6";
+    name = "${pname}-${version}";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "0imbb68i5n5fm704gv47if1blpxd4f8g16qmp5ar07cavgh2mibl";
+    };
+
+    propagatedBuildInputs = [ nose ];
+
+    meta = with stdenv.lib; {
+      description = "A small Python library to parse various kinds of time expressions";
+      homepage    = "https://github.com/wroberts/pytimeparse";
+      license     = licenses.mit;
+      maintainers = with maintainers; [ vrthra ];
+    };
+}