about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2016-04-16 21:06:42 +0300
committerTuomas Tynkkynen <tuomas@tuxera.com>2016-04-16 21:06:42 +0300
commit908aac3ca73ac0b7dbcd3933329fa13c21416506 (patch)
treeeeb25e3d485028c1dd7760b348e5465d978720ad /pkgs/development
parent5ac500ae685039f0c5faa55bc280a67889aa7f30 (diff)
parenta8272280d7f46bd71a8e40669c3bc4564d295757 (diff)
downloadnixlib-908aac3ca73ac0b7dbcd3933329fa13c21416506.tar
nixlib-908aac3ca73ac0b7dbcd3933329fa13c21416506.tar.gz
nixlib-908aac3ca73ac0b7dbcd3933329fa13c21416506.tar.bz2
nixlib-908aac3ca73ac0b7dbcd3933329fa13c21416506.tar.lz
nixlib-908aac3ca73ac0b7dbcd3933329fa13c21416506.tar.xz
nixlib-908aac3ca73ac0b7dbcd3933329fa13c21416506.tar.zst
nixlib-908aac3ca73ac0b7dbcd3933329fa13c21416506.zip
Merge remote-tracking branch 'upstream/master' into staging
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/gcc/4.9/default.nix9
-rw-r--r--pkgs/development/compilers/ghcjs/default.nix8
-rw-r--r--pkgs/development/compilers/ghcjs/shims.nix4
-rw-r--r--pkgs/development/haskell-modules/ghcjs/stage2.nix2
-rw-r--r--pkgs/development/libraries/nghttp2/default.nix2
5 files changed, 13 insertions, 12 deletions
diff --git a/pkgs/development/compilers/gcc/4.9/default.nix b/pkgs/development/compilers/gcc/4.9/default.nix
index 74612ae77548..2d568980fd45 100644
--- a/pkgs/development/compilers/gcc/4.9/default.nix
+++ b/pkgs/development/compilers/gcc/4.9/default.nix
@@ -73,8 +73,8 @@ let version = "4.9.3";
       ++ optional langAda ../gnat-cflags.patch
       ++ optional langFortran ../gfortran-driving.patch
       # The NXConstStr.patch can be removed at 4.9.4
-      ++ optional stdenv.isDarwin ../gfortran-darwin-NXConstStr.patch; 
-	  
+      ++ optional stdenv.isDarwin ../gfortran-darwin-NXConstStr.patch;
+
     javaEcj = fetchurl {
       # The `$(top_srcdir)/ecj.jar' file is automatically picked up at
       # `configure' time.
@@ -218,7 +218,8 @@ stdenv.mkDerivation ({
 
   inherit patches;
 
-  outputs = if langJava then ["out" "man" "info"] else [ "out" "lib" "man" "info" ];
+  outputs = if langJava || langGo then ["out" "man" "info"]
+    else [ "out" "lib" "man" "info" ];
   setOutputFlags = false;
   NIX_NO_SELF_RPATH = true;
 
@@ -316,7 +317,7 @@ stdenv.mkDerivation ({
       )
     fi
   ''
-  + stdenv.lib.optionalString langJava ''
+  + stdenv.lib.optionalString (langJava || langGo) ''
     export lib=$out;
   ''
   ;
diff --git a/pkgs/development/compilers/ghcjs/default.nix b/pkgs/development/compilers/ghcjs/default.nix
index e18c3213a3c0..929d59a9a9bc 100644
--- a/pkgs/development/compilers/ghcjs/default.nix
+++ b/pkgs/development/compilers/ghcjs/default.nix
@@ -40,8 +40,8 @@
 
 , ghcjsBootSrc ? fetchgit {
     url = git://github.com/ghcjs/ghcjs-boot.git;
-    rev = "97dea5c4145bf80a1e7cffeb1ecd4d0ecacd5a2f";
-    sha256 = "1cgjzm595l2dx6fibzbkyv23bp1857qia0hb9d8aghf006al558j";
+    rev = "758e79e420403e0f6625eda19b10c46564f7cbb5";
+    sha256 = "0gq1mc86cb2z875a7sdj44yy8g95rwxzkl3z1q8gg33k05s3b58r";
     fetchSubmodules = true;
   }
 , ghcjsBoot ? import ./ghcjs-boot.nix {
@@ -60,8 +60,8 @@ in mkDerivation (rec {
   src = fetchFromGitHub {
     owner = "ghcjs";
     repo = "ghcjs";
-    rev = "13a99c6da40e3700e070e430d4c0f2ea96217b24";
-    sha256 = "01yg6babmhn2bfbmgkddisfj9ai7fc4r08s6acd49s9amcw7g5ld";
+    rev = "689c7753f50353dd05606ed79c51cd5a94d3922a";
+    sha256 = "076020a9gjv8ldj5ckm43sbzq9s6c5xj6lpd8v28ybpiama3m6b4";
   };
   isLibrary = true;
   isExecutable = true;
diff --git a/pkgs/development/compilers/ghcjs/shims.nix b/pkgs/development/compilers/ghcjs/shims.nix
index 2d68ea075515..0da50570bf59 100644
--- a/pkgs/development/compilers/ghcjs/shims.nix
+++ b/pkgs/development/compilers/ghcjs/shims.nix
@@ -2,6 +2,6 @@
 fetchFromGitHub {
   owner = "ghcjs";
   repo = "shims";
-  rev = "4df1808d03117ddcd45f276f0ddd85c73e59506a";
-  sha256 = "0nay4pmq3yqqvpz23709i3729840idpcc2ii2jd0xvaj1z61adda";
+  rev = "dc034a035aa73db2c5be34145732090bd74c1b57";
+  sha256 = "18r8kf7g7d2n0rhwcgiz9gsgdmgln1nmwwyj347bpn4zh17qlkqa";
 }
diff --git a/pkgs/development/haskell-modules/ghcjs/stage2.nix b/pkgs/development/haskell-modules/ghcjs/stage2.nix
index f84ddbdefa45..4b31e77ca7bd 100644
--- a/pkgs/development/haskell-modules/ghcjs/stage2.nix
+++ b/pkgs/development/haskell-modules/ghcjs/stage2.nix
@@ -324,7 +324,7 @@
       }:
       mkDerivation {
         pname = "Cabal";
-        version = "1.22.4.0";
+        version = "1.22.8.0";
         src = "${ghcjsBoot}/boot/cabal/Cabal";
         doCheck = false;
         libraryHaskellDepends = [
diff --git a/pkgs/development/libraries/nghttp2/default.nix b/pkgs/development/libraries/nghttp2/default.nix
index e6f76ce27ea7..761f6933f5c4 100644
--- a/pkgs/development/libraries/nghttp2/default.nix
+++ b/pkgs/development/libraries/nghttp2/default.nix
@@ -38,7 +38,7 @@ stdenv.mkDerivation rec {
 
   # Don't use fetchFromGitHub since this needs a bootstrap curl
   src = fetchurl {
-    url = "http://http.debian.net/debian/pool/main/n/nghttp2/nghttp2_${version}.orig.tar.bz2";
+    url = "https://github.com/nghttp2/nghttp2/releases/download/v${version}/nghttp2-${version}.tar.bz2";
     sha256 = "10xz3s624w208pr9xgm4ammc8bc5mi17vy4357hjfd5vmmp5m8b0";
   };