about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorBas van Dijk <v.dijk.bas@gmail.com>2019-01-07 12:13:13 +0100
committerGitHub <noreply@github.com>2019-01-07 12:13:13 +0100
commit8ad610b0401a545d649aa66650027499c283b658 (patch)
tree77faef13b8ab3980af632359ce6dc65a275e05bc /pkgs/development
parent6c54f9ea5a4370160483820040fec301389c005a (diff)
parent2118e66fc310297e9a8ebe0cfb25fe7583206477 (diff)
downloadnixlib-8ad610b0401a545d649aa66650027499c283b658.tar
nixlib-8ad610b0401a545d649aa66650027499c283b658.tar.gz
nixlib-8ad610b0401a545d649aa66650027499c283b658.tar.bz2
nixlib-8ad610b0401a545d649aa66650027499c283b658.tar.lz
nixlib-8ad610b0401a545d649aa66650027499c283b658.tar.xz
nixlib-8ad610b0401a545d649aa66650027499c283b658.tar.zst
nixlib-8ad610b0401a545d649aa66650027499c283b658.zip
Merge pull request #53523 from jacereda/futhark-darwin
Fix futhark build on Darwin
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/futhark/default.nix55
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix2
-rw-r--r--pkgs/development/haskell-modules/non-hackage-packages.nix3
3 files changed, 1 insertions, 59 deletions
diff --git a/pkgs/development/compilers/futhark/default.nix b/pkgs/development/compilers/futhark/default.nix
deleted file mode 100644
index 890be3431c3a..000000000000
--- a/pkgs/development/compilers/futhark/default.nix
+++ /dev/null
@@ -1,55 +0,0 @@
-# Generated using `cabal2nix --hpack .`, then replace src
-{ mkDerivation, alex, array, base, bifunctors, binary, blaze-html
-, bytestring, containers, data-binary-ieee754, directory
-, directory-tree, dlist, extra, file-embed, filepath, gitrev, happy
-, haskeline, hpack, HUnit, json, language-c-quote, mainland-pretty
-, markdown, mtl, neat-interpolation, parallel, parsec, process
-, process-extras, QuickCheck, random, raw-strings-qq, regex-tdfa
-, srcloc, stdenv, template-haskell, temporary, test-framework
-, test-framework-hunit, test-framework-quickcheck2, text
-, th-lift-instances, transformers, vector, vector-binary-instances
-, zlib, fetchFromGitHub
-}:
-mkDerivation {
-  pname = "futhark";
-  version = "0.6.2";
-  src = fetchFromGitHub {
-    owner = "diku-dk";
-    repo = "futhark";
-    rev = "v0.6.2";
-    sha256 = "0yj7n01swpvqblybdnks3mjf0mzf1gdg2b2cpxdpxnrjw5j0pnq2";
-  };
-  isLibrary = true;
-  isExecutable = true;
-  libraryHaskellDepends = [
-    array base bifunctors binary blaze-html bytestring containers
-    data-binary-ieee754 directory directory-tree dlist extra file-embed
-    filepath gitrev language-c-quote mainland-pretty markdown mtl
-    neat-interpolation parallel parsec process raw-strings-qq
-    regex-tdfa srcloc template-haskell text th-lift-instances
-    transformers vector vector-binary-instances zlib
-  ];
-  libraryToolDepends = [ alex happy hpack ];
-  executableHaskellDepends = [
-    array base bifunctors binary blaze-html bytestring containers
-    data-binary-ieee754 directory directory-tree dlist extra file-embed
-    filepath gitrev haskeline json language-c-quote mainland-pretty
-    markdown mtl neat-interpolation parallel parsec process
-    process-extras random raw-strings-qq regex-tdfa srcloc
-    template-haskell temporary text th-lift-instances transformers
-    vector vector-binary-instances zlib
-  ];
-  testHaskellDepends = [
-    array base bifunctors binary blaze-html bytestring containers
-    data-binary-ieee754 directory directory-tree dlist extra file-embed
-    filepath gitrev HUnit language-c-quote mainland-pretty markdown mtl
-    neat-interpolation parallel parsec process QuickCheck
-    raw-strings-qq regex-tdfa srcloc template-haskell test-framework
-    test-framework-hunit test-framework-quickcheck2 text
-    th-lift-instances transformers vector vector-binary-instances zlib
-  ];
-  preConfigure = "hpack";
-  homepage = "https://futhark-lang.org";
-  description = "An optimising compiler for a functional, array-oriented language";
-  license = stdenv.lib.licenses.isc;
-}
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index d34d9193c23a..6fdb2fd54949 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -532,7 +532,7 @@ self: super: builtins.intersectAttrs super {
   # The test-suite requires a running PostgreSQL server.
   Frames-beam = dontCheck super.Frames-beam;
 
-  futhark = with pkgs;
+  futhark = if pkgs.stdenv.isDarwin then super.futhark else with pkgs;
     let path = stdenv.lib.makeBinPath [ gcc ];
     in overrideCabal (addBuildTool super.futhark makeWrapper) (_drv: {
       postInstall = ''
diff --git a/pkgs/development/haskell-modules/non-hackage-packages.nix b/pkgs/development/haskell-modules/non-hackage-packages.nix
index 68fcbdb79a5d..b7b057f2dc20 100644
--- a/pkgs/development/haskell-modules/non-hackage-packages.nix
+++ b/pkgs/development/haskell-modules/non-hackage-packages.nix
@@ -12,7 +12,4 @@ self: super: {
 
   # https://github.com/channable/vaultenv/issues/1
   vaultenv = self.callPackage ../tools/haskell/vaultenv { };
-
-  # https://github.com/diku-dk/futhark/issues/614
-  futhark = self.callPackage ../compilers/futhark { };
 }