about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2017-06-28 13:54:38 +0200
committerGitHub <noreply@github.com>2017-06-28 13:54:38 +0200
commit8a62a9b064ed52da5ab2fd9520cdd218ce4445cb (patch)
tree3091c1b3830ba15792487a68db57d05a9fa6b715 /pkgs/development
parenta6cf6367e2abd9610da804286cc6c439d79717db (diff)
parentb7ccf27229d9479e5cea2f2d2c2b06477d9e3049 (diff)
downloadnixlib-8a62a9b064ed52da5ab2fd9520cdd218ce4445cb.tar
nixlib-8a62a9b064ed52da5ab2fd9520cdd218ce4445cb.tar.gz
nixlib-8a62a9b064ed52da5ab2fd9520cdd218ce4445cb.tar.bz2
nixlib-8a62a9b064ed52da5ab2fd9520cdd218ce4445cb.tar.lz
nixlib-8a62a9b064ed52da5ab2fd9520cdd218ce4445cb.tar.xz
nixlib-8a62a9b064ed52da5ab2fd9520cdd218ce4445cb.tar.zst
nixlib-8a62a9b064ed52da5ab2fd9520cdd218ce4445cb.zip
Merge pull request #26125 from volth/webkitgtk-naming
rename webkitgtk24x⇒webkitgtk24x-gtk3; webkitgtk2⇒webkitgtk24x-gtk2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix4
-rw-r--r--pkgs/development/haskell-modules/hackage-packages.nix24
-rw-r--r--pkgs/development/libraries/wxwidgets/3.0/default.nix6
3 files changed, 17 insertions, 17 deletions
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index 584ea5eb71df..89827e8c9d9e 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -129,8 +129,8 @@ self: super: builtins.intersectAttrs super {
   gtksourceview2 = addPkgconfigDepend super.gtksourceview2 pkgs.gtk2;
 
   # Need WebkitGTK, not just webkit.
-  webkit = super.webkit.override { webkit = pkgs.webkitgtk2; };
-  websnap = super.websnap.override { webkit = pkgs.webkitgtk24x; };
+  webkit = super.webkit.override { webkit = pkgs.webkitgtk24x-gtk2; };
+  websnap = super.websnap.override { webkit = pkgs.webkitgtk24x-gtk3; };
 
   hs-mesos = overrideCabal super.hs-mesos (drv: {
     # Pass _only_ mesos; the correct protobuf is propagated.
diff --git a/pkgs/development/haskell-modules/hackage-packages.nix b/pkgs/development/haskell-modules/hackage-packages.nix
index 65ad24320c8e..5694fe5faf8d 100644
--- a/pkgs/development/haskell-modules/hackage-packages.nix
+++ b/pkgs/development/haskell-modules/hackage-packages.nix
@@ -75046,7 +75046,7 @@ self: {
 
   "gi-javascriptcore" = callPackage
     ({ mkDerivation, base, bytestring, Cabal, containers, haskell-gi
-     , haskell-gi-base, text, transformers, webkitgtk24x
+     , haskell-gi-base, text, transformers, webkitgtk24x-gtk3
      }:
      mkDerivation {
        pname = "gi-javascriptcore";
@@ -75057,13 +75057,13 @@ self: {
          base bytestring containers haskell-gi haskell-gi-base text
          transformers
        ];
-       libraryPkgconfigDepends = [ webkitgtk24x ];
+       libraryPkgconfigDepends = [ webkitgtk24x-gtk3 ];
        doHaddock = false;
        homepage = "https://github.com/haskell-gi/haskell-gi";
        description = "JavaScriptCore bindings";
        license = stdenv.lib.licenses.lgpl21;
        hydraPlatforms = stdenv.lib.platforms.none;
-     }) {inherit (pkgs) webkitgtk24x;};
+     }) {inherit (pkgs) webkitgtk24x-gtk3;};
 
   "gi-javascriptcore_4_0_12" = callPackage
     ({ mkDerivation, base, bytestring, Cabal, containers, haskell-gi
@@ -75272,7 +75272,7 @@ self: {
     ({ mkDerivation, base, bytestring, Cabal, containers, gi-atk
      , gi-cairo, gi-gdk, gi-gdkpixbuf, gi-gio, gi-glib, gi-gobject
      , gi-gtk, gi-javascriptcore, gi-soup, haskell-gi, haskell-gi-base
-     , text, transformers, webkitgtk24x
+     , text, transformers, webkitgtk24x-gtk3
      }:
      mkDerivation {
        pname = "gi-webkit";
@@ -75284,13 +75284,13 @@ self: {
          gi-gio gi-glib gi-gobject gi-gtk gi-javascriptcore gi-soup
          haskell-gi haskell-gi-base text transformers
        ];
-       libraryPkgconfigDepends = [ webkitgtk24x ];
+       libraryPkgconfigDepends = [ webkitgtk24x-gtk3 ];
        doHaddock = false;
        homepage = "https://github.com/haskell-gi/haskell-gi";
        description = "WebKit bindings";
        license = stdenv.lib.licenses.lgpl21;
        hydraPlatforms = stdenv.lib.platforms.none;
-     }) {inherit (pkgs) webkitgtk24x;};
+     }) {inherit (pkgs) webkitgtk24x-gtk3;};
 
   "gi-webkit2" = callPackage
     ({ mkDerivation, base, bytestring, Cabal, containers, gi-atk
@@ -201493,7 +201493,7 @@ self: {
   "webkitgtk3" = callPackage
     ({ mkDerivation, base, bytestring, Cabal, cairo, glib
      , gtk2hs-buildtools, gtk3, mtl, pango, text, transformers
-     , webkitgtk24x
+     , webkitgtk24x-gtk3
      }:
      mkDerivation {
        pname = "webkitgtk3";
@@ -201503,26 +201503,26 @@ self: {
        libraryHaskellDepends = [
          base bytestring cairo glib gtk3 mtl pango text transformers
        ];
-       libraryPkgconfigDepends = [ webkitgtk24x ];
+       libraryPkgconfigDepends = [ webkitgtk24x-gtk3 ];
        homepage = "http://projects.haskell.org/gtk2hs/";
        description = "Binding to the Webkit library";
        license = stdenv.lib.licenses.lgpl21;
        hydraPlatforms = stdenv.lib.platforms.none;
-     }) {inherit (pkgs) webkitgtk24x;};
+     }) {inherit (pkgs) webkitgtk24x-gtk3;};
 
   "webkitgtk3-javascriptcore" = callPackage
-    ({ mkDerivation, base, Cabal, gtk2hs-buildtools, webkitgtk24x }:
+    ({ mkDerivation, base, Cabal, gtk2hs-buildtools, webkitgtk24x-gtk3 }:
      mkDerivation {
        pname = "webkitgtk3-javascriptcore";
        version = "0.14.2.1";
        sha256 = "0kcjrka0c9ifq3zfhmkv05wy3xb7v0cyznfxldp2gjcn1haq084j";
        setupHaskellDepends = [ base Cabal gtk2hs-buildtools ];
        libraryHaskellDepends = [ base ];
-       libraryPkgconfigDepends = [ webkitgtk24x ];
+       libraryPkgconfigDepends = [ webkitgtk24x-gtk3 ];
        description = "JavaScriptCore FFI from webkitgtk";
        license = stdenv.lib.licenses.bsd3;
        hydraPlatforms = stdenv.lib.platforms.none;
-     }) {inherit (pkgs) webkitgtk24x;};
+     }) {inherit (pkgs) webkitgtk24x-gtk3;};
 
   "webpage" = callPackage
     ({ mkDerivation, base, blaze-html, data-default, lucid, text }:
diff --git a/pkgs/development/libraries/wxwidgets/3.0/default.nix b/pkgs/development/libraries/wxwidgets/3.0/default.nix
index 5b1e0fc067c7..ef32575c8e36 100644
--- a/pkgs/development/libraries/wxwidgets/3.0/default.nix
+++ b/pkgs/development/libraries/wxwidgets/3.0/default.nix
@@ -2,13 +2,13 @@
 , xf86vidmodeproto , gstreamer, gst-plugins-base, GConf, setfile
 , withMesa ? true, mesa_glu ? null, mesa_noglu ? null
 , compat24 ? false, compat26 ? true, unicode ? true
-, withWebKit ? false, webkitgtk2 ? null
+, withWebKit ? false, webkitgtk24x-gtk2 ? null
 , AGL ? null, Carbon ? null, Cocoa ? null, Kernel ? null, QTKit ? null
 }:
 
 
 assert withMesa -> mesa_glu != null && mesa_noglu != null;
-assert withWebKit -> webkitgtk2 != null;
+assert withWebKit -> webkitgtk24x-gtk2 != null;
 
 with stdenv.lib;
 
@@ -27,7 +27,7 @@ stdenv.mkDerivation {
     [ gtk2 libXinerama libSM libXxf86vm xf86vidmodeproto gstreamer
       gst-plugins-base GConf ]
     ++ optional withMesa mesa_glu
-    ++ optional withWebKit webkitgtk2
+    ++ optional withWebKit webkitgtk24x-gtk2
     ++ optionals stdenv.isDarwin [ setfile Carbon Cocoa Kernel QTKit ];
 
   nativeBuildInputs = [ pkgconfig ];