about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorAlexey Shmalko <rasen.dubi@gmail.com>2016-06-20 22:52:20 +0300
committerAlexey Shmalko <rasen.dubi@gmail.com>2016-06-20 22:52:20 +0300
commit87aa864ff94403e01629761948b6d7e572481948 (patch)
tree1e8ec79db3a03d08ab4e03e0ca50d03105ae606a /pkgs/development
parent099d3dc43b5d9c0bb977df96965469310198a3fa (diff)
downloadnixlib-87aa864ff94403e01629761948b6d7e572481948.tar
nixlib-87aa864ff94403e01629761948b6d7e572481948.tar.gz
nixlib-87aa864ff94403e01629761948b6d7e572481948.tar.bz2
nixlib-87aa864ff94403e01629761948b6d7e572481948.tar.lz
nixlib-87aa864ff94403e01629761948b6d7e572481948.tar.xz
nixlib-87aa864ff94403e01629761948b6d7e572481948.tar.zst
nixlib-87aa864ff94403e01629761948b6d7e572481948.zip
haskell-hoogle: adapt to GHC docs split
The docs were split at #16167 and broke google support. @peti fixed
build, however hoogle still didn't see packages shipped with GHC. This
patch fixes location of the libraries shipped with GHC.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/hoogle.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/development/haskell-modules/hoogle.nix b/pkgs/development/haskell-modules/hoogle.nix
index 65aaaf4dbcaf..3cb1efbce739 100644
--- a/pkgs/development/haskell-modules/hoogle.nix
+++ b/pkgs/development/haskell-modules/hoogle.nix
@@ -79,7 +79,7 @@ stdenv.mkDerivation {
     }
 
     echo importing builtin packages
-    for docdir in ${ghc}/${docLibGlob}/*; do
+    for docdir in ${ghc.doc}/${docLibGlob}/*; do
       name="$(basename $docdir)"
       ${opts isGhcjs ''docdir="$docdir/html"''}
       if [[ -d $docdir ]]; then