about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2010-04-13 08:56:14 +0000
committerLudovic Courtès <ludo@gnu.org>2010-04-13 08:56:14 +0000
commit8251c938e8a7346bac253e1b8c9b9e3082820876 (patch)
tree826438d1964f7893a6b07e73ecb770c480e30325 /pkgs/development
parent9170abe84dd2271bc58e045f5a2e5777c1beb04f (diff)
downloadnixlib-8251c938e8a7346bac253e1b8c9b9e3082820876.tar
nixlib-8251c938e8a7346bac253e1b8c9b9e3082820876.tar.gz
nixlib-8251c938e8a7346bac253e1b8c9b9e3082820876.tar.bz2
nixlib-8251c938e8a7346bac253e1b8c9b9e3082820876.tar.lz
nixlib-8251c938e8a7346bac253e1b8c9b9e3082820876.tar.xz
nixlib-8251c938e8a7346bac253e1b8c9b9e3082820876.tar.zst
nixlib-8251c938e8a7346bac253e1b8c9b9e3082820876.zip
GNU Common C++ 1.8.0.
svn path=/nixpkgs/trunk/; revision=21053
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/commoncpp2/default.nix40
1 files changed, 28 insertions, 12 deletions
diff --git a/pkgs/development/libraries/commoncpp2/default.nix b/pkgs/development/libraries/commoncpp2/default.nix
index 28ba597e0354..8f519a4b43c8 100644
--- a/pkgs/development/libraries/commoncpp2/default.nix
+++ b/pkgs/development/libraries/commoncpp2/default.nix
@@ -1,20 +1,36 @@
-args: with args;
-stdenv.mkDerivation {
-  name = "commoncpp2-2.0.8";
+{ fetchurl, stdenv }:
+
+stdenv.mkDerivation rec {
+  name = "commoncpp2-1.8.0";
 
   src = fetchurl {
-    url = http://ftp.gnu.org/pub/gnu/commoncpp/ucommon-2.0.8.tar.gz;
-    sha256 = "09mk70kqwr1pmxa35x0is16g2sa60b3z8p4p5yccw59pp1hpxpq3";
+    url = "mirror://gnu/commoncpp/${name}.tar.gz";
+    sha256 = "0a7arpm9l3s5qics5m77lyx1yl7998lkypydqwx11nj730034nmc";
   };
 
-  buildInputs = [];
+  doCheck = true;
+
+  meta = {
+    description = "GNU Common C++, a portable, highly optimized C++ class framework";
 
-  meta = { 
-    description = "highly portable application framework for threading,sockets, realtime network streaming, persistance, and file access";
+    longDescription =
+      '' GNU Common C++ and GNU uCommon are very portable and highly
+         optimized class framework for writing C++ applications that need to
+         use threads and support concurrent sychronization, and that use
+         sockets, XML parsing, object serialization, thread-optimized String
+         and data structure classes, etc.  This framework offers a class
+         foundation that hides platform differences from your C++ application
+         so that you need not write platform specific code.  GNU Common C++
+         has been ported to compile nativily on most platforms which support
+         either posix threads, or on maybe be used with Debian hosted mingw32
+         to build native threading applications for Microsoft Windows.
+      '';
 
-    homepage = http://sourceforge.net/projects/cplusplus/;
-    license = "LGPL";
-    maintainers = [args.lib.maintainers.marcweber];
-    platforms = args.lib.platforms.linux;
+    homepage = http://www.gnu.org/software/commoncpp/;
+    license = "GPLv2+";
+    maintainers = [ stdenv.lib.maintainers.marcweber
+                    stdenv.lib.maintainers.ludo
+                  ];
+    platforms = stdenv.lib.platforms.all;
   };
 }