about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLangston Barrett <langston.barrett@gmail.com>2017-07-03 23:31:49 +0000
committerFrederik Rietdijk <fridh@fridh.nl>2017-07-28 16:13:28 +0200
commit822b09a5145c08e116451a9dfc248def12c5e90c (patch)
treec6e42467bbc2af921039fd331d6184389326d133 /pkgs/development
parentd2c0a46797cdb3d8fe337a8d77ae7870e3cc9fef (diff)
downloadnixlib-822b09a5145c08e116451a9dfc248def12c5e90c.tar
nixlib-822b09a5145c08e116451a9dfc248def12c5e90c.tar.gz
nixlib-822b09a5145c08e116451a9dfc248def12c5e90c.tar.bz2
nixlib-822b09a5145c08e116451a9dfc248def12c5e90c.tar.lz
nixlib-822b09a5145c08e116451a9dfc248def12c5e90c.tar.xz
nixlib-822b09a5145c08e116451a9dfc248def12c5e90c.tar.zst
nixlib-822b09a5145c08e116451a9dfc248def12c5e90c.zip
ukpostcodeparser: init at 1.1.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/ukpostcodeparser/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/ukpostcodeparser/default.nix b/pkgs/development/python-modules/ukpostcodeparser/default.nix
new file mode 100644
index 000000000000..6eae1f524561
--- /dev/null
+++ b/pkgs/development/python-modules/ukpostcodeparser/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, lib, buildPythonPackage, fetchPypi }:
+
+buildPythonPackage rec {
+  pname = "UkPostcodeParser";
+  version = "1.1.0";
+  name = "${pname}-${version}";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1v8k91xhg5fr6sk91am93abjarw950ray7b9q3w5j25agjsxgcsf";
+  };
+
+  doCheck = false;
+
+  meta = with lib; {
+    description = "UK Postcode parser";
+    homepage    = https://github.com/hamstah/ukpostcodeparser;
+    license     = licenses.publicDomain;
+    maintainers = with maintainers; [ siddharthist ];
+    platforms   = platforms.unix;
+  };
+}