about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2019-03-26 17:15:50 +0100
committerPeter Simons <simons@cryp.to>2019-03-26 17:20:35 +0100
commit803e956919ef1c14a0403250201d510c36ace64e (patch)
tree63a9c38595381c012f942f8449d4035f0f51e571 /pkgs/development
parent999450f7d308cf343179b15ecc60b62eac09325e (diff)
downloadnixlib-803e956919ef1c14a0403250201d510c36ace64e.tar
nixlib-803e956919ef1c14a0403250201d510c36ace64e.tar.gz
nixlib-803e956919ef1c14a0403250201d510c36ace64e.tar.bz2
nixlib-803e956919ef1c14a0403250201d510c36ace64e.tar.lz
nixlib-803e956919ef1c14a0403250201d510c36ace64e.tar.xz
nixlib-803e956919ef1c14a0403250201d510c36ace64e.tar.zst
nixlib-803e956919ef1c14a0403250201d510c36ace64e.zip
liquidhaskell: switch ghc-8.6.x version to the 'develop' branch to fix the build
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-8.6.x.nix21
-rw-r--r--pkgs/development/haskell-modules/configuration-hackage2nix.yaml4
-rw-r--r--pkgs/development/haskell-modules/hackage-packages.nix4
3 files changed, 23 insertions, 6 deletions
diff --git a/pkgs/development/haskell-modules/configuration-ghc-8.6.x.nix b/pkgs/development/haskell-modules/configuration-ghc-8.6.x.nix
index 2d382e906325..5a856032e47c 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-8.6.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-8.6.x.nix
@@ -67,4 +67,25 @@ self: super: {
   # Break out of "yaml >=0.10.4.0 && <0.11": https://github.com/commercialhaskell/stack/issues/4485
   stack = doJailbreak super.stack;
 
+  # Needs a recent version from the "develop" branch of the upstream git
+  # repository to compile with ghc 8.6.4.
+  liquid-fixpoint = assert super.liquid-fixpoint.version == "0.7.0.7"; overrideSrc super.liquid-fixpoint {
+    src = pkgs.fetchFromGitHub {
+      owner = "ucsd-progsys";
+      repo = "liquid-fixpoint";
+      rev = "42c027ab9ae47907c588a2f1f9c05a5e0aa881e9";
+      sha256 = "17qmzq1vx7h04yd38drr6sh6hys3q2rz62qh3pna9kbxlcnikkqf";
+    };
+    version = "0.8.0.2-pre-release";
+  };
+  liquidhaskell = assert super.liquidhaskell.version == "0.8.2.4"; overrideSrc super.liquidhaskell {
+    src = pkgs.fetchFromGitHub {
+      owner = "ucsd-progsys";
+      repo = "liquidhaskell";
+      rev = "254e77da9cd36e95b72c526bfb9eec50d3447050";
+      sha256 = "089x41z51iw542ijz32j9ns6flcc4hsbjqx7rfznvmm7a4q78yza";
+    };
+    version = "0.8.6.0-pre-release";
+  };
+
 }
diff --git a/pkgs/development/haskell-modules/configuration-hackage2nix.yaml b/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
index 5ce43c0909c9..911929db28b9 100644
--- a/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
+++ b/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
@@ -2431,6 +2431,8 @@ package-maintainers:
     - lambdabot-core
     - lambdabot-irc-plugins
     - language-nix
+    - liquid-fixpoint
+    - liquidhaskell
     - logging-facade-syslog
     - nix-paths
     - pandoc
@@ -6570,8 +6572,6 @@ broken-packages:
   - lio-simple
   - lipsum-gen
   - liquid
-  - liquid-fixpoint
-  - liquidhaskell
   - liquidhaskell-cabal
   - liquidhaskell-cabal-demo
   - list-fusion-probe
diff --git a/pkgs/development/haskell-modules/hackage-packages.nix b/pkgs/development/haskell-modules/hackage-packages.nix
index f4c6298aa156..442db85c824a 100644
--- a/pkgs/development/haskell-modules/hackage-packages.nix
+++ b/pkgs/development/haskell-modules/hackage-packages.nix
@@ -143442,8 +143442,6 @@ self: {
        doCheck = false;
        description = "Predicate Abstraction-based Horn-Clause/Implication Constraint Solver";
        license = stdenv.lib.licenses.bsd3;
-       hydraPlatforms = stdenv.lib.platforms.none;
-       broken = true;
      }) {inherit (pkgs) git; inherit (pkgs) nettools; 
          inherit (pkgs) ocaml; inherit (pkgs) z3;};
 
@@ -143486,8 +143484,6 @@ self: {
        testSystemDepends = [ z3 ];
        description = "Liquid Types for Haskell";
        license = stdenv.lib.licenses.bsd3;
-       hydraPlatforms = stdenv.lib.platforms.none;
-       broken = true;
      }) {inherit (pkgs) z3;};
 
   "liquidhaskell-cabal" = callPackage