about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-12-05 12:44:02 +0000
committerGitHub <noreply@github.com>2017-12-05 12:44:02 +0000
commit7e6068c3533cf67ffbcbbd902f586650a76c3b0a (patch)
tree89450e6a1f00600b8847fd5b323d636d66ed342b /pkgs/development
parent8e97f8fac4a5ccd07d78547848d0c5164c060519 (diff)
parent7e39ecba684a9e1e64a6f18c69543a170a36bd52 (diff)
downloadnixlib-7e6068c3533cf67ffbcbbd902f586650a76c3b0a.tar
nixlib-7e6068c3533cf67ffbcbbd902f586650a76c3b0a.tar.gz
nixlib-7e6068c3533cf67ffbcbbd902f586650a76c3b0a.tar.bz2
nixlib-7e6068c3533cf67ffbcbbd902f586650a76c3b0a.tar.lz
nixlib-7e6068c3533cf67ffbcbbd902f586650a76c3b0a.tar.xz
nixlib-7e6068c3533cf67ffbcbbd902f586650a76c3b0a.tar.zst
nixlib-7e6068c3533cf67ffbcbbd902f586650a76c3b0a.zip
Merge pull request #32335 from makefu/pkgs/devpi-common/update
init devpi-server at 4.3.1, bump devpi-client
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/argon2_cffi/default.nix31
-rw-r--r--pkgs/development/python-modules/devpi-common/default.nix6
-rw-r--r--pkgs/development/python-modules/passlib/default.nix5
-rw-r--r--pkgs/development/python-modules/pytest-timeout/default.nix27
-rw-r--r--pkgs/development/tools/devpi-client/default.nix47
-rw-r--r--pkgs/development/tools/devpi-server/default.nix27
6 files changed, 123 insertions, 20 deletions
diff --git a/pkgs/development/python-modules/argon2_cffi/default.nix b/pkgs/development/python-modules/argon2_cffi/default.nix
new file mode 100644
index 000000000000..80985f868c7a
--- /dev/null
+++ b/pkgs/development/python-modules/argon2_cffi/default.nix
@@ -0,0 +1,31 @@
+{ lib
+, cffi
+, six
+, hypothesis
+, pytest
+, wheel
+, buildPythonPackage
+, fetchPypi
+}:
+
+buildPythonPackage rec {
+  pname = "argon2_cffi";
+  version = "16.3.0";
+  name    = "${pname}-${version}";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1ap3il3j1pjyprrhpfyhc21izpmhzhfb5s69vlzc65zvd1nj99cr";
+  };
+
+  propagatedBuildInputs = [ cffi six ];
+  checkInputs = [ hypothesis pytest wheel ];
+  checkPhase = ''
+    pytest tests
+  '';
+
+  meta = {
+    description = "Secure Password Hashes for Python";
+    homepage    = https://argon2-cffi.readthedocs.io/;
+  };
+}
diff --git a/pkgs/development/python-modules/devpi-common/default.nix b/pkgs/development/python-modules/devpi-common/default.nix
index 67f8debc43a0..f2be8ec56381 100644
--- a/pkgs/development/python-modules/devpi-common/default.nix
+++ b/pkgs/development/python-modules/devpi-common/default.nix
@@ -2,20 +2,18 @@
 
 with pythonPackages;buildPythonPackage rec {
   pname = "devpi-common";
-  version = "3.1.0";
+  version = "3.2.0";
   name = "${pname}-${version}";
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "d89634a57981ed43cb5dcd25e00c9454ea111189c5ddc08d945b3d5187ada5fd";
+    sha256 = "0rh119iw5hk41gsvbjr0wixvl1i4f0b1vcnw9ym35rmcp517z0wb";
   };
 
   propagatedBuildInputs = [ requests py ];
   checkInputs = [ pytest ];
 
   checkPhase = ''
-    # Don't know why this test is failing!
-    substituteInPlace testing/test_request.py --replace "test_env" "noop_test_env"
     py.test
   '';
 
diff --git a/pkgs/development/python-modules/passlib/default.nix b/pkgs/development/python-modules/passlib/default.nix
index c269a414f82d..165de7bd2baf 100644
--- a/pkgs/development/python-modules/passlib/default.nix
+++ b/pkgs/development/python-modules/passlib/default.nix
@@ -3,6 +3,7 @@
 , fetchPypi
 , nose
 , bcrypt
+, argon2_cffi
 }:
 
 buildPythonPackage rec {
@@ -16,10 +17,10 @@ buildPythonPackage rec {
   };
 
   checkInputs = [ nose ];
-  propagatedBuildInputs = [ bcrypt ];
+  propagatedBuildInputs = [ bcrypt argon2_cffi ];
 
   meta = {
     description = "A password hashing library for Python";
     homepage    = https://code.google.com/p/passlib/;
   };
-}
\ No newline at end of file
+}
diff --git a/pkgs/development/python-modules/pytest-timeout/default.nix b/pkgs/development/python-modules/pytest-timeout/default.nix
new file mode 100644
index 000000000000..d3a4e375ec3a
--- /dev/null
+++ b/pkgs/development/python-modules/pytest-timeout/default.nix
@@ -0,0 +1,27 @@
+{ buildPythonPackage
+, fetchPypi
+, lib
+, pexpect
+, pytest
+}:
+
+buildPythonPackage rec {
+  pname = "pytest-timeout";
+  version = "1.2.1";
+  name = "${pname}-${version}";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1kdp6qbh5v1168l99rba5yfzvy05gmzkmkhldgp36p9xcdjd5dv8";
+  };
+  buildInputs = [ pytest ];
+  checkInputs = [ pytest pexpect ];
+  checkPhase = ''pytest -ra'';
+
+  meta = with lib;{
+    description = "py.test plugin to abort hanging tests";
+    homepage = http://bitbucket.org/pytest-dev/pytest-timeout/;
+    license = licenses.mit;
+    maintainers = with maintainers; [ makefu ];
+  };
+}
diff --git a/pkgs/development/tools/devpi-client/default.nix b/pkgs/development/tools/devpi-client/default.nix
index 9da88f6c63d8..6a98befd346e 100644
--- a/pkgs/development/tools/devpi-client/default.nix
+++ b/pkgs/development/tools/devpi-client/default.nix
@@ -1,28 +1,47 @@
-{ stdenv, pythonPackages, glibcLocales} :
+{ stdenv
+, lib
+, pythonPackages
+, glibcLocales
+, devpi-server
+, git
+, mercurial
+} :
 
 pythonPackages.buildPythonApplication rec {
   name = "${pname}-${version}";
   pname = "devpi-client";
-  version = "3.1.0rc1";
+  version = "3.1.0";
 
   src = pythonPackages.fetchPypi {
     inherit pname version;
-    sha256 = "0kfyva886k9zxmilqb2yviwqzyvs3n36if3s56y4clbvw9hr2lc3";
+    sha256 = "0w47x3lkafcg9ijlaxllmq4886nsc91w49ck1cd7vn2gafkwjkgr";
   };
-  # requires devpi-server which is currently not packaged
-  doCheck = true;
-  checkInputs = with pythonPackages; [ pytest webtest mock ];
-  checkPhase = "py.test";
+
+  checkInputs = with pythonPackages; [
+                    pytest webtest mock
+                    devpi-server tox
+                    sphinx wheel git mercurial detox
+                    setuptools
+                    ];
+  checkPhase = ''
+    export PATH=$PATH:$out/bin
+
+    # setuptools do not get propagated into the tox call (cannot import setuptools)
+    rm testing/test_test.py
+
+    # test tries to connect to upstream pypi
+    py.test -k 'not test_pypi_index_attributes' testing
+  '';
 
   LC_ALL = "en_US.UTF-8";
-  buildInputs = with pythonPackages; [ glibcLocales pkginfo tox check-manifest ];
-  propagatedBuildInputs = with pythonPackages; [ py devpi-common pluggy ];
+  buildInputs = with pythonPackages; [ glibcLocales pkginfo check-manifest ];
+  propagatedBuildInputs = with pythonPackages; [ py devpi-common pluggy setuptools ];
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://doc.devpi.net;
-    description = "Github-style pypi index server and packaging meta tool";
-    license = stdenv.lib.licenses.mit;
-    maintainers = with stdenv.lib.maintainers; [ lewo makefu ];
-
+    description = "Client for devpi, a pypi index server and packaging meta tool";
+    license = licenses.mit;
+    maintainers = with maintainers; [ lewo makefu ];
   };
+
 }
diff --git a/pkgs/development/tools/devpi-server/default.nix b/pkgs/development/tools/devpi-server/default.nix
new file mode 100644
index 000000000000..275e411fc8d7
--- /dev/null
+++ b/pkgs/development/tools/devpi-server/default.nix
@@ -0,0 +1,27 @@
+ { stdenv, pythonPackages, glibcLocales, nginx }:
+
+pythonPackages.buildPythonApplication rec {
+  name = "${pname}-${version}";
+  pname = "devpi-server";
+  version = "4.3.1";
+
+  src = pythonPackages.fetchPypi {
+    inherit pname version;
+    sha256 = "0x6ks2sbpknznxaqlh0gf5hcvhkmgixixq2zs91wgfqxk4vi4s6n";
+  };
+
+  propagatedBuildInputs = with pythonPackages;
+    [ devpi-common execnet itsdangerous pluggy waitress pyramid passlib ];
+  checkInputs = with pythonPackages; [ nginx webtest pytest beautifulsoup4 pytest-timeout pytest-catchlog mock pyyaml ];
+  checkPhase = ''
+    cd test_devpi_server/
+    PATH=$PATH:$out/bin pytest --slow -rfsxX
+  '';
+
+  meta = with stdenv.lib;{
+    homepage = http://doc.devpi.net;
+    description = "Github-style pypi index server and packaging meta tool";
+    license = licenses.mit;
+    maintainers = with maintainers; [ makefu ];
+  };
+}