about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLangston Barrett <langston.barrett@gmail.com>2017-07-13 00:32:27 +0000
committerLangston Barrett <langston.barrett@gmail.com>2017-07-13 00:32:27 +0000
commit7b27f7c28fda894b7a625790889f6caca048b9f3 (patch)
treeb1647ad75b30459358564716c7a36ce66cacaf93 /pkgs/development
parenteb28340bacf12fa795802c7a8a9c923271c70d12 (diff)
downloadnixlib-7b27f7c28fda894b7a625790889f6caca048b9f3.tar
nixlib-7b27f7c28fda894b7a625790889f6caca048b9f3.tar.gz
nixlib-7b27f7c28fda894b7a625790889f6caca048b9f3.tar.bz2
nixlib-7b27f7c28fda894b7a625790889f6caca048b9f3.tar.lz
nixlib-7b27f7c28fda894b7a625790889f6caca048b9f3.tar.xz
nixlib-7b27f7c28fda894b7a625790889f6caca048b9f3.tar.zst
nixlib-7b27f7c28fda894b7a625790889f6caca048b9f3.zip
pycodestyle: 2.0.0 -> 2.3.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pycodestyle/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/pycodestyle/default.nix b/pkgs/development/python-modules/pycodestyle/default.nix
new file mode 100644
index 000000000000..e6c7a85aaf28
--- /dev/null
+++ b/pkgs/development/python-modules/pycodestyle/default.nix
@@ -0,0 +1,19 @@
+{ lib, buildPythonPackage, fetchPypi }:
+
+buildPythonPackage rec {
+  pname = "pycodestyle";
+  version = "2.3.1";
+  name = "${pname}-${version}";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0rk78b66p57ala26mdldl9lafr48blv5s659sah9q50qnfjmc8k8";
+  };
+
+  meta = with lib; {
+    description = "Python style guide checker (formerly called pep8)";
+    homepage = https://pycodestyle.readthedocs.io;
+    license = licenses.mit;
+    maintainers = with maintainers; [ garbas ];
+  };
+}