about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2018-11-10 14:00:32 +0000
committerJörg Thalheim <joerg@thalheim.io>2018-11-11 11:16:44 +0000
commit7a86bc32cb6c038313890a09a1f6f4cc13c6f542 (patch)
tree5943c309c8cd20e88d5ac7ebade172b5dfe6ad8f /pkgs/development
parent0a7d20ece5f0d75e22cda4e2d665aec356310707 (diff)
downloadnixlib-7a86bc32cb6c038313890a09a1f6f4cc13c6f542.tar
nixlib-7a86bc32cb6c038313890a09a1f6f4cc13c6f542.tar.gz
nixlib-7a86bc32cb6c038313890a09a1f6f4cc13c6f542.tar.bz2
nixlib-7a86bc32cb6c038313890a09a1f6f4cc13c6f542.tar.lz
nixlib-7a86bc32cb6c038313890a09a1f6f4cc13c6f542.tar.xz
nixlib-7a86bc32cb6c038313890a09a1f6f4cc13c6f542.tar.zst
nixlib-7a86bc32cb6c038313890a09a1f6f4cc13c6f542.zip
docker-compose: rename from docker_compose, python3 by default
The command is called docker-compose hence the package should be called the same.
Also prefer python3.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/docker_compose/default.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/pkgs/development/python-modules/docker_compose/default.nix b/pkgs/development/python-modules/docker_compose/default.nix
deleted file mode 100644
index 4af9c32fed6a..000000000000
--- a/pkgs/development/python-modules/docker_compose/default.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{ stdenv, buildPythonApplication, fetchPypi, pythonOlder
-, mock, pytest, nose
-, pyyaml, backports_ssl_match_hostname, colorama, docopt
-, dockerpty, docker, ipaddress, jsonschema, requests
-, six, texttable, websocket_client, cached-property
-, enum34, functools32,
-}:
-buildPythonApplication rec {
-  version = "1.23.1";
-  pname = "docker-compose";
-
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "15jijx3md70b9xw8818xjm70nr9pc27p7v7is0yi6agf8scvvqkq";
-  };
-
-  # lots of networking and other fails
-  doCheck = false;
-  checkInputs = [ mock pytest nose ];
-  propagatedBuildInputs = [
-    pyyaml backports_ssl_match_hostname colorama dockerpty docker
-    ipaddress jsonschema requests six texttable websocket_client
-    docopt cached-property
-  ] ++
-    stdenv.lib.optional (pythonOlder "3.4") enum34 ++
-    stdenv.lib.optional (pythonOlder "3.2") functools32;
-
-  postPatch = ''
-    # Remove upper bound on requires, see also
-    # https://github.com/docker/compose/issues/4431
-    sed -i "s/, < .*',$/',/" setup.py
-  '';
-
-  postInstall = ''
-    mkdir -p $out/share/bash-completion/completions/
-    cp contrib/completion/bash/docker-compose $out/share/bash-completion/completions/docker-compose
-  '';
-
-  meta = with stdenv.lib; {
-    homepage = https://docs.docker.com/compose/;
-    description = "Multi-container orchestration for Docker";
-    license = licenses.asl20;
-    maintainers = with maintainers; [
-      jgeerds
-    ];
-  };
-}