about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2015-09-15 15:02:39 +0200
committerPeter Simons <simons@cryp.to>2015-09-15 16:23:46 +0200
commit7802f5c79394d0fd347059c23b4528f4679ea076 (patch)
tree66de6b0e0de68944444b01e61d9409729b2af81c /pkgs/development
parent974f2122b1163de0315c51fc161cdb97b66d6111 (diff)
downloadnixlib-7802f5c79394d0fd347059c23b4528f4679ea076.tar
nixlib-7802f5c79394d0fd347059c23b4528f4679ea076.tar.gz
nixlib-7802f5c79394d0fd347059c23b4528f4679ea076.tar.bz2
nixlib-7802f5c79394d0fd347059c23b4528f4679ea076.tar.lz
nixlib-7802f5c79394d0fd347059c23b4528f4679ea076.tar.xz
nixlib-7802f5c79394d0fd347059c23b4528f4679ea076.tar.zst
nixlib-7802f5c79394d0fd347059c23b4528f4679ea076.zip
haskell.lib: add doDistribute function as a dual to dontDistribute
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/lib.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/lib.nix b/pkgs/development/haskell-modules/lib.nix
index 635fc317b284..7ac30668d8fe 100644
--- a/pkgs/development/haskell-modules/lib.nix
+++ b/pkgs/development/haskell-modules/lib.nix
@@ -17,6 +17,7 @@ rec {
   doCheck = drv: overrideCabal drv (drv: { doCheck = true; });
   dontCheck = drv: overrideCabal drv (drv: { doCheck = false; });
 
+  doDistribute = drv: overrideCabal drv (drv: { hydraPlatforms = drv.platforms or ["i686-linux" "x86_64-linux" "x86_64-darwin"]; });
   dontDistribute = drv: overrideCabal drv (drv: { hydraPlatforms = []; });
 
   appendConfigureFlag = drv: x: overrideCabal drv (drv: { configureFlags = (drv.configureFlags or []) ++ [x]; });