about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFabian Affolter <mail@fabian-affolter.ch>2022-12-09 10:50:32 +0100
committerGitHub <noreply@github.com>2022-12-09 10:50:32 +0100
commit74778be2f150a843bab0ec8dbc31fb3f1e477323 (patch)
treef3e6a09811e29bc5f021464b02b8759645aa7617 /pkgs/development
parente7c28692fa9fba03173c021aeaba4953fbf7441a (diff)
downloadnixlib-74778be2f150a843bab0ec8dbc31fb3f1e477323.tar
nixlib-74778be2f150a843bab0ec8dbc31fb3f1e477323.tar.gz
nixlib-74778be2f150a843bab0ec8dbc31fb3f1e477323.tar.bz2
nixlib-74778be2f150a843bab0ec8dbc31fb3f1e477323.tar.lz
nixlib-74778be2f150a843bab0ec8dbc31fb3f1e477323.tar.xz
nixlib-74778be2f150a843bab0ec8dbc31fb3f1e477323.tar.zst
nixlib-74778be2f150a843bab0ec8dbc31fb3f1e477323.zip
python310Packages.pysmart: add changelog to meta
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pysmart/default.nix17
1 files changed, 12 insertions, 5 deletions
diff --git a/pkgs/development/python-modules/pysmart/default.nix b/pkgs/development/python-modules/pysmart/default.nix
index b5c45e2c02c7..35773b483975 100644
--- a/pkgs/development/python-modules/pysmart/default.nix
+++ b/pkgs/development/python-modules/pysmart/default.nix
@@ -14,7 +14,7 @@ buildPythonPackage rec {
     owner = "truenas";
     repo = "py-SMART";
     rev = "refs/tags/v${version}";
-    sha256 = "sha256-slLk4zoW0ht9hiOxyBt0caekjrPgih9G99pRiD2vIxE=";
+    hash = "sha256-slLk4zoW0ht9hiOxyBt0caekjrPgih9G99pRiD2vIxE=";
   };
 
   postPatch = ''
@@ -22,16 +22,23 @@ buildPythonPackage rec {
       --replace "which('smartctl')" '"${smartmontools}/bin/smartctl"'
   '';
 
-  propagatedBuildInputs = [ humanfriendly ];
+  propagatedBuildInputs = [
+    humanfriendly
+  ];
 
-  checkInputs = [ pytestCheckHook ];
+  checkInputs = [
+    pytestCheckHook
+  ];
 
-  pythonImportsCheck = [ "pySMART" ];
+  pythonImportsCheck = [
+    "pySMART"
+  ];
 
   meta = with lib; {
     description = "Wrapper for smartctl (smartmontools)";
     homepage = "https://github.com/truenas/py-SMART";
-    maintainers = with maintainers; [ nyanloutre ];
+    changelog = "https://github.com/truenas/py-SMART/blob/v${version}/CHANGELOG.md";
     license = licenses.lgpl21Only;
+    maintainers = with maintainers; [ nyanloutre ];
   };
 }