about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorzimbatm <zimbatm@zimbatm.com>2016-03-10 10:04:47 +0000
committerzimbatm <zimbatm@zimbatm.com>2016-03-10 10:04:47 +0000
commit73de4019f025d6d1e77f5e530799a7a34e2015f9 (patch)
tree8493b0cbe465fcbfbd6c71be11f8d61a34c572fd /pkgs/development
parent76f8ee24187a087506fb63602d318e1b991a2aa0 (diff)
parent4939b6848f600e20baad00a31bd9734554a6191e (diff)
downloadnixlib-73de4019f025d6d1e77f5e530799a7a34e2015f9.tar
nixlib-73de4019f025d6d1e77f5e530799a7a34e2015f9.tar.gz
nixlib-73de4019f025d6d1e77f5e530799a7a34e2015f9.tar.bz2
nixlib-73de4019f025d6d1e77f5e530799a7a34e2015f9.tar.lz
nixlib-73de4019f025d6d1e77f5e530799a7a34e2015f9.tar.xz
nixlib-73de4019f025d6d1e77f5e530799a7a34e2015f9.tar.zst
nixlib-73de4019f025d6d1e77f5e530799a7a34e2015f9.zip
Merge pull request #13784 from matthewbauer/new-pkgs
add wla-dx and rgbds
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/rgbds/default.nix22
-rw-r--r--pkgs/development/compilers/wla-dx/default.nix24
2 files changed, 46 insertions, 0 deletions
diff --git a/pkgs/development/compilers/rgbds/default.nix b/pkgs/development/compilers/rgbds/default.nix
new file mode 100644
index 000000000000..827dd774e788
--- /dev/null
+++ b/pkgs/development/compilers/rgbds/default.nix
@@ -0,0 +1,22 @@
+{stdenv, fetchFromGitHub, yacc}:
+
+stdenv.mkDerivation rec {
+  name = "rgbds-${version}";
+  version = "0.2.4";
+  src = fetchFromGitHub {
+    owner = "bentley";
+    repo = "rgbds";
+    rev = "v${version}";
+    sha256 = "0dwq0p9g1lci8sm12a2rfk0g33z2vr75x78zdf1g84djwbz8ipc6";
+  };
+  nativeBuildInputs = [ yacc ];
+  installFlags = "PREFIX=\${out}";
+
+  meta = with stdenv.lib; {
+    homepage = "https://www.anjbe.name/rgbds/";
+    description = "An assembler/linker package that produces Game Boy programs";
+    license = licenses.free;
+    maintainers = with maintainers; [ mbauer ];
+    platforms = platforms.all;
+  };
+}
diff --git a/pkgs/development/compilers/wla-dx/default.nix b/pkgs/development/compilers/wla-dx/default.nix
new file mode 100644
index 000000000000..535868bee3ba
--- /dev/null
+++ b/pkgs/development/compilers/wla-dx/default.nix
@@ -0,0 +1,24 @@
+{stdenv, fetchFromGitHub, cmake}:
+
+stdenv.mkDerivation rec {
+  name = "wla-dx-git-2016-02-27";
+  src = fetchFromGitHub {
+    owner = "vhelin";
+    repo = "wla-dx";
+    rev = "8189fe8d5620584ea16563875ff3c5430527c86a";
+    sha256 = "02zgkcyfx7y8j6jvyi12lm29fydnd7m3rxv6g2psv23fyzmpkkir";
+  };
+  installPhase = ''
+    mkdir -p $out/bin
+    install binaries/* $out/bin
+  '';
+  nativeBuildInputs = [ cmake ];
+
+  meta = with stdenv.lib; {
+    homepage = "http://www.villehelin.com/wla.html";
+    description = "Yet Another GB-Z80/Z80/6502/65C02/6510/65816/HUC6280/SPC-700 Multi Platform Cross Assembler Package";
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ mbauer ];
+    platforms = platforms.all;
+  };
+}