about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authoradisbladis <adisbladis@gmail.com>2019-09-06 15:10:39 +0100
committeradisbladis <adisbladis@gmail.com>2019-09-07 12:48:42 +0100
commit723148f92e2de56d22a2b25cb95864cd0d9fc7ef (patch)
treed859ab740489d8fc944b073f717b89676bcf88c9 /pkgs/development
parent3ab433df342c4196a8210fa631ceece9096a445b (diff)
downloadnixlib-723148f92e2de56d22a2b25cb95864cd0d9fc7ef.tar
nixlib-723148f92e2de56d22a2b25cb95864cd0d9fc7ef.tar.gz
nixlib-723148f92e2de56d22a2b25cb95864cd0d9fc7ef.tar.bz2
nixlib-723148f92e2de56d22a2b25cb95864cd0d9fc7ef.tar.lz
nixlib-723148f92e2de56d22a2b25cb95864cd0d9fc7ef.tar.xz
nixlib-723148f92e2de56d22a2b25cb95864cd0d9fc7ef.tar.zst
nixlib-723148f92e2de56d22a2b25cb95864cd0d9fc7ef.zip
elastic7: 7.0.1 -> 7.3.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/elasticsearch-curator/default.nix4
-rw-r--r--pkgs/development/tools/misc/kibana/7.x.nix12
-rw-r--r--pkgs/development/tools/misc/kibana/disable-nodejs-version-check-7.patch19
3 files changed, 29 insertions, 6 deletions
diff --git a/pkgs/development/python-modules/elasticsearch-curator/default.nix b/pkgs/development/python-modules/elasticsearch-curator/default.nix
index d517af949d47..e95d1aaba022 100644
--- a/pkgs/development/python-modules/elasticsearch-curator/default.nix
+++ b/pkgs/development/python-modules/elasticsearch-curator/default.nix
@@ -45,6 +45,10 @@ buildPythonPackage rec {
     funcsigs
   ];
 
+  postPatch = ''
+    sed -i s/pyyaml==3.12/pyyaml==${pyyaml.version}/ setup.cfg setup.py
+  '';
+
   meta = with stdenv.lib; {
     homepage = https://github.com/elastic/curator;
     description = "Curate, or manage, your Elasticsearch indices and snapshots";
diff --git a/pkgs/development/tools/misc/kibana/7.x.nix b/pkgs/development/tools/misc/kibana/7.x.nix
index 2fc0242c014b..fb4dca8d5490 100644
--- a/pkgs/development/tools/misc/kibana/7.x.nix
+++ b/pkgs/development/tools/misc/kibana/7.x.nix
@@ -18,12 +18,12 @@ let
   shas =
     if enableUnfree
     then {
-      x86_64-linux  = "1mzycd0ljnkslz9p9jhq279bkpk35r7svhngxjnmsh11ampsvxb8";
-      x86_64-darwin = "1bz409njdpmsagh5dg062114wpa96w7pmxwfjsizwksqyyjdwdv7";
+      "x86_64-linux"  = "0sc5709k3z7lb8qcjpj49s6vfv69ds2wc8319ag9x776nyz1pqxi";
+      "x86_64-darwin" = "0zh4q46vfdwaihs838ck8fap92i3b4x10wbpmx8mcwyfk5v0fkch";
     }
     else {
-      x86_64-linux  = "1x3gjc9xa03m4jfnl5vjxigzcnb8ysnhxgd8618v85x4l0010v38";
-      x86_64-darwin = "1nsbmrswv2jv2z7686i2sf6rrmxysbqi5ih6jjrbrqnk64xi18j2";
+      "x86_64-linux"  = "1pq17fasryharvw4byybvmcf5172hcmy6cp0m8bxhkxagwilprba";
+      "x86_64-darwin" = "11crpx2qs2nzkzv6fvs1gqn9v4zalxkzsc5br0fy1y02lzm26zbm";
     };
 
 in stdenv.mkDerivation rec {
@@ -32,14 +32,14 @@ in stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "https://artifacts.elastic.co/downloads/kibana/${name}-${plat}-${arch}.tar.gz";
-    sha256 = shas.${stdenv.hostPlatform.system} or (throw "Unknown architecture");
+    sha256 = shas."${stdenv.hostPlatform.system}" or (throw "Unknown architecture");
   };
 
   patches = [
     # Kibana specifies it specifically needs nodejs 10.15.2 but nodejs in nixpkgs is at 10.15.3.
     # The <nixpkgs/nixos/tests/elk.nix> test succeeds with this newer version so lets just
     # disable the version check.
-    ./disable-nodejs-version-check.patch
+    ./disable-nodejs-version-check-7.patch
   ];
 
   buildInputs = [ makeWrapper ];
diff --git a/pkgs/development/tools/misc/kibana/disable-nodejs-version-check-7.patch b/pkgs/development/tools/misc/kibana/disable-nodejs-version-check-7.patch
new file mode 100644
index 000000000000..ef4c207764c1
--- /dev/null
+++ b/pkgs/development/tools/misc/kibana/disable-nodejs-version-check-7.patch
@@ -0,0 +1,19 @@
+diff --git a/src/setup_node_env/node_version_validator.js b/src/setup_node_env/node_version_validator.js
+index 3f611e5a..f5c60c85 100644
+--- a/src/setup_node_env/node_version_validator.js
++++ b/src/setup_node_env/node_version_validator.js
+@@ -25,11 +25,11 @@ var pkg = require('../../package.json'); // Note: This is written in ES5 so we c
+ var currentVersion = process && process.version || null;
+ var rawRequiredVersion = pkg && pkg.engines && pkg.engines.node || null;
+ var requiredVersion = rawRequiredVersion ? 'v' + rawRequiredVersion : rawRequiredVersion;
+-var isVersionValid = !!currentVersion && !!requiredVersion && currentVersion === requiredVersion; // Validates current the NodeJS version compatibility when Kibana starts.
++var isVersionValid = !!currentVersion && !!requiredVersion; // Validates current the NodeJS version compatibility when Kibana starts.
+ 
+ if (!isVersionValid) {
+   var errorMessage = 'Kibana does not support the current Node.js version ' + currentVersion + '. Please use Node.js ' + requiredVersion + '.'; // Actions to apply when validation fails: error report + exit.
+ 
+   console.error(errorMessage);
+   process.exit(1);
+-}
+\ No newline at end of file
++}