about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2018-07-17 17:37:50 -0400
committerShea Levy <shea@shealevy.com>2018-07-17 17:37:50 -0400
commit711c56dd67de03718367222cdcb46714da9e68b2 (patch)
tree75902f37c6fa3b787997b7d44c2dc59882008c02 /pkgs/development
parent90223e4a4a60556e7b706c69480593557b8a2fb9 (diff)
downloadnixlib-711c56dd67de03718367222cdcb46714da9e68b2.tar
nixlib-711c56dd67de03718367222cdcb46714da9e68b2.tar.gz
nixlib-711c56dd67de03718367222cdcb46714da9e68b2.tar.bz2
nixlib-711c56dd67de03718367222cdcb46714da9e68b2.tar.lz
nixlib-711c56dd67de03718367222cdcb46714da9e68b2.tar.xz
nixlib-711c56dd67de03718367222cdcb46714da9e68b2.tar.zst
nixlib-711c56dd67de03718367222cdcb46714da9e68b2.zip
pythonPackages.simpy: init at 3.0.11.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/simpy/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/simpy/default.nix b/pkgs/development/python-modules/simpy/default.nix
new file mode 100644
index 000000000000..981b6693f7d4
--- /dev/null
+++ b/pkgs/development/python-modules/simpy/default.nix
@@ -0,0 +1,18 @@
+{ buildPythonPackage, fetchPypi, lib }:
+
+buildPythonPackage rec {
+  pname = "simpy";
+  version = "3.0.11";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0hqgxk3lggf21jq9lh8838cdl24mdkdnpzh0w4m28d0zn2wjb5nh";
+  };
+
+  meta = with lib; {
+    homepage = https://simpy.readthedocs.io/en/latest/;
+    description = "A process-based discrete-event simulation framework based on standard Python.";
+    license = [ licenses.mit ];
+    maintainers = with maintainers; [ shlevy ];
+  };
+}