about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2020-04-03 20:47:04 +0200
committerPeter Simons <simons@cryp.to>2020-04-03 22:00:29 +0200
commit70a22c5b4b5cb2b3003ea4b734fadbc7a37792ba (patch)
treecd9c9d1633fd31bdbec971359eb2020ebdf1afdb /pkgs/development
parentfbb1a3f080a748819930f2ca9e720cf174179701 (diff)
downloadnixlib-70a22c5b4b5cb2b3003ea4b734fadbc7a37792ba.tar
nixlib-70a22c5b4b5cb2b3003ea4b734fadbc7a37792ba.tar.gz
nixlib-70a22c5b4b5cb2b3003ea4b734fadbc7a37792ba.tar.bz2
nixlib-70a22c5b4b5cb2b3003ea4b734fadbc7a37792ba.tar.lz
nixlib-70a22c5b4b5cb2b3003ea4b734fadbc7a37792ba.tar.xz
nixlib-70a22c5b4b5cb2b3003ea4b734fadbc7a37792ba.tar.zst
nixlib-70a22c5b4b5cb2b3003ea4b734fadbc7a37792ba.zip
haskell-matterhorn: fix override
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix15
1 files changed, 4 insertions, 11 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index e34126053df2..5c44fe17f91a 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -1463,17 +1463,10 @@ self: super: {
   # haskell-ci-0.8 needs cabal-install-parsers ==0.1, but we have 0.2.
   haskell-ci = doJailbreak super.haskell-ci;
 
-  # 2020-01-19 - there were conflicting versions of brick, vty, and brick-skylighting;
-  # multiple versions of them were being pulled in by the others which is not allowed.
-  # There are more complicated ways of doing this but I was able to make it fairly simple -- kiwi
-  # 2020-03-31 - "..." it broke again. so here's a more complicated way -- kiwi
-  matterhorn = super.matterhorn.override {
-    brick-skylighting = self.brick-skylighting.override {
-      brick = self.brick_0_52_1.override {
-        vty = self.vty_5_28_2;
-      };
-    };
-  };
+  # Needs the latest version of vty.
+  matterhorn = super.matterhorn.overrideScope (self: super: {
+    vty = self.vty_5_28_2;
+  });
 
   persistent-mysql = dontCheck super.persistent-mysql;