about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2022-12-09 11:19:42 +0100
committerGitHub <noreply@github.com>2022-12-09 11:19:42 +0100
commit6f246095c2d6643b41d63665008fabd823754605 (patch)
tree86b8b3cd11aa9fa79f08e7566fe2eeb398060d3a /pkgs/development
parent05c1c92897b8e7774e642a7714976d19670fd6b5 (diff)
parentea0b637cda710838afb0856098ece6d5e9774b7f (diff)
downloadnixlib-6f246095c2d6643b41d63665008fabd823754605.tar
nixlib-6f246095c2d6643b41d63665008fabd823754605.tar.gz
nixlib-6f246095c2d6643b41d63665008fabd823754605.tar.bz2
nixlib-6f246095c2d6643b41d63665008fabd823754605.tar.lz
nixlib-6f246095c2d6643b41d63665008fabd823754605.tar.xz
nixlib-6f246095c2d6643b41d63665008fabd823754605.tar.zst
nixlib-6f246095c2d6643b41d63665008fabd823754605.zip
Merge pull request #205085 from r-ryantm/auto-update/python3.10-pysmart
python310Packages.pysmart: 1.1.0 -> 1.2.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pysmart/default.nix25
1 files changed, 18 insertions, 7 deletions
diff --git a/pkgs/development/python-modules/pysmart/default.nix b/pkgs/development/python-modules/pysmart/default.nix
index 3bd5fa50a133..5c576e4895ff 100644
--- a/pkgs/development/python-modules/pysmart/default.nix
+++ b/pkgs/development/python-modules/pysmart/default.nix
@@ -4,17 +4,21 @@
 , smartmontools
 , humanfriendly
 , pytestCheckHook
+, pythonOlder
 }:
 
 buildPythonPackage rec {
   pname = "pysmart";
-  version = "1.1.0";
+  version = "1.2.1";
+  format = "setuptools";
+
+  disabled = pythonOlder "3.7";
 
   src = fetchFromGitHub {
     owner = "truenas";
     repo = "py-SMART";
-    rev = "v${version}";
-    sha256 = "sha256-e46ALiYg0Db/gOzqLmVc1vi9ObhfxzqwfQk9/9pz+r0=";
+    rev = "refs/tags/v${version}";
+    hash = "sha256-slLk4zoW0ht9hiOxyBt0caekjrPgih9G99pRiD2vIxE=";
   };
 
   postPatch = ''
@@ -22,16 +26,23 @@ buildPythonPackage rec {
       --replace "which('smartctl')" '"${smartmontools}/bin/smartctl"'
   '';
 
-  propagatedBuildInputs = [ humanfriendly ];
+  propagatedBuildInputs = [
+    humanfriendly
+  ];
 
-  checkInputs = [ pytestCheckHook ];
+  checkInputs = [
+    pytestCheckHook
+  ];
 
-  pythonImportsCheck = [ "pySMART" ];
+  pythonImportsCheck = [
+    "pySMART"
+  ];
 
   meta = with lib; {
     description = "Wrapper for smartctl (smartmontools)";
     homepage = "https://github.com/truenas/py-SMART";
-    maintainers = with maintainers; [ nyanloutre ];
+    changelog = "https://github.com/truenas/py-SMART/blob/v${version}/CHANGELOG.md";
     license = licenses.lgpl21Only;
+    maintainers = with maintainers; [ nyanloutre ];
   };
 }