about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDaiderd Jordan <daiderd@gmail.com>2018-10-27 14:43:54 +0100
committerGitHub <noreply@github.com>2018-10-27 14:43:54 +0100
commit6e677351aa99d69b9a6ac6ece4bd45f058105aba (patch)
treee43e2438cdfec356bdd2ff2a40eb042a9099b611 /pkgs/development
parent4b6958173722075ec5c294936e1ab9e1376cb443 (diff)
parent8284f09dcda1cb7b6e70ae34b9fbfd341a96b3a7 (diff)
downloadnixlib-6e677351aa99d69b9a6ac6ece4bd45f058105aba.tar
nixlib-6e677351aa99d69b9a6ac6ece4bd45f058105aba.tar.gz
nixlib-6e677351aa99d69b9a6ac6ece4bd45f058105aba.tar.bz2
nixlib-6e677351aa99d69b9a6ac6ece4bd45f058105aba.tar.lz
nixlib-6e677351aa99d69b9a6ac6ece4bd45f058105aba.tar.xz
nixlib-6e677351aa99d69b9a6ac6ece4bd45f058105aba.tar.zst
nixlib-6e677351aa99d69b9a6ac6ece4bd45f058105aba.zip
Merge pull request #49261 from holidaycheck/fix-bats
bats: add missing grep dependency
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/bats/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/development/interpreters/bats/default.nix b/pkgs/development/interpreters/bats/default.nix
index 081f1a547d69..85794b09ae0b 100644
--- a/pkgs/development/interpreters/bats/default.nix
+++ b/pkgs/development/interpreters/bats/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchzip }:
+{ stdenv, fetchzip, gnugrep }:
 
 stdenv.mkDerivation rec {
   name = "bats-${version}";
@@ -9,7 +9,10 @@ stdenv.mkDerivation rec {
     sha256 = "1kkh0j2alql3xiyhw9wsvcc3xclv52g0ivgyk8h85q9fn3qdqakz";
   };
 
-  patchPhase = "patchShebangs ./install.sh";
+  patchPhase = ''
+    patchShebangs ./install.sh
+    substituteInPlace ./libexec/bats-core/bats-format-tap-stream --replace grep ${gnugrep}/bin/grep
+  '';
 
   installPhase = "./install.sh $out";