about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMathieu Boespflug <m@tweag.io>2016-04-17 01:09:24 +0200
committerMathieu Boespflug <m@tweag.io>2016-04-17 01:09:24 +0200
commit6c9c59067b1927f37f02a23d2cbe776d8cb6c1fc (patch)
treec6a7e4c28c94a0eec4f9bf28b4de312a2184e471 /pkgs/development
parentc316210f2951908de6569cb4afadc9c5e114a585 (diff)
downloadnixlib-6c9c59067b1927f37f02a23d2cbe776d8cb6c1fc.tar
nixlib-6c9c59067b1927f37f02a23d2cbe776d8cb6c1fc.tar.gz
nixlib-6c9c59067b1927f37f02a23d2cbe776d8cb6c1fc.tar.bz2
nixlib-6c9c59067b1927f37f02a23d2cbe776d8cb6c1fc.tar.lz
nixlib-6c9c59067b1927f37f02a23d2cbe776d8cb6c1fc.tar.xz
nixlib-6c9c59067b1927f37f02a23d2cbe776d8cb6c1fc.tar.zst
nixlib-6c9c59067b1927f37f02a23d2cbe776d8cb6c1fc.zip
gradle: fix attribute name for gcc libs path.
PR #14326 fixed gradle so that its native code library could find
libstdc++.so.6, but this fix is inoperative now, because this library
is in `"${stdenv.cc.cc.lib}/lib"` now, rather than
`"${stdenv.cc.cc}/lib"`.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/build-managers/gradle/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/development/tools/build-managers/gradle/default.nix b/pkgs/development/tools/build-managers/gradle/default.nix
index 96477e55d26a..730d42073759 100644
--- a/pkgs/development/tools/build-managers/gradle/default.nix
+++ b/pkgs/development/tools/build-managers/gradle/default.nix
@@ -22,7 +22,7 @@ rec {
         mkdir patching
         pushd patching
         jar xf $out/lib/gradle/lib/native-platform-linux-${arch}-0.10.jar
-        patchelf --set-rpath "${stdenv.cc.cc}/lib:${stdenv.cc.cc}/lib64" net/rubygrapefruit/platform/linux-${arch}/libnative-platform.so
+        patchelf --set-rpath "${stdenv.cc.cc.lib}/lib:${stdenv.cc.cc.lib}/lib64" net/rubygrapefruit/platform/linux-${arch}/libnative-platform.so
         jar cf native-platform-linux-${arch}-0.10.jar .
         mv native-platform-linux-${arch}-0.10.jar $out/lib/gradle/lib/
         popd