about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorAl Zohali <zohl@fmap.me>2016-02-09 13:46:39 +0300
committerAl Zohali <zohl@fmap.me>2016-03-07 23:21:01 +0300
commit6c9269670e32e0a0d95547aa21187c6c5917e876 (patch)
tree8809db420cd22cad4681fca4842cc65e48e38082 /pkgs/development
parenta347e45c545fc3f7b84cd37169385805050e6cbc (diff)
downloadnixlib-6c9269670e32e0a0d95547aa21187c6c5917e876.tar
nixlib-6c9269670e32e0a0d95547aa21187c6c5917e876.tar.gz
nixlib-6c9269670e32e0a0d95547aa21187c6c5917e876.tar.bz2
nixlib-6c9269670e32e0a0d95547aa21187c6c5917e876.tar.lz
nixlib-6c9269670e32e0a0d95547aa21187c6c5917e876.tar.xz
nixlib-6c9269670e32e0a0d95547aa21187c6c5917e876.tar.zst
nixlib-6c9269670e32e0a0d95547aa21187c6c5917e876.zip
mono-zeroconf: init at 0.9.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/mono-zeroconf/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/development/libraries/mono-zeroconf/default.nix b/pkgs/development/libraries/mono-zeroconf/default.nix
new file mode 100644
index 000000000000..12b15c4937d7
--- /dev/null
+++ b/pkgs/development/libraries/mono-zeroconf/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchurl, autoreconfHook, which, pkgconfig, mono }:
+
+stdenv.mkDerivation rec {
+  name = "mono-zeroconf-${version}";
+  version = "0.9.0";
+
+  src = fetchurl {
+    url = "http://download.banshee-project.org/mono-zeroconf/mono-zeroconf-${version}.tar.bz2";
+    sha256 = "1qfp4qvsx7rc2shj1chi2y7fxn10rwi70rw2y54b2i8a4jq7gpkb";
+  };
+
+  buildInputs = [ pkgconfig which mono ];
+
+  dontStrip = true;
+
+  configureFlags = [ "--disable-docs" ];
+
+  meta = with stdenv.lib; {
+    description = "A cross platform Zero Configuration Networking library for Mono and .NET";
+    homepage = http://www.mono-project.com/archived/monozeroconf/;
+    platforms = platforms.linux;
+  };
+}