about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorsternenseemann <sternenseemann@systemli.org>2022-03-20 00:39:39 +0100
committersternenseemann <sternenseemann@systemli.org>2022-03-20 00:40:38 +0100
commit6b25081893536afdd18e9a134e8c9418130dc13f (patch)
treeeadffe578508e3d81ed7059a6601bc19c57e16ed /pkgs/development
parent177255c8aac086b4ea999252a2f042b94e478091 (diff)
downloadnixlib-6b25081893536afdd18e9a134e8c9418130dc13f.tar
nixlib-6b25081893536afdd18e9a134e8c9418130dc13f.tar.gz
nixlib-6b25081893536afdd18e9a134e8c9418130dc13f.tar.bz2
nixlib-6b25081893536afdd18e9a134e8c9418130dc13f.tar.lz
nixlib-6b25081893536afdd18e9a134e8c9418130dc13f.tar.xz
nixlib-6b25081893536afdd18e9a134e8c9418130dc13f.tar.zst
nixlib-6b25081893536afdd18e9a134e8c9418130dc13f.zip
haskellPackages.{alg,category,util}: work around Safe Haskell error
Workaround taken from https://github.com/strake/util.hs/issues/1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index e176b74c50b8..f533bbd62d5c 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -1706,6 +1706,21 @@ self: super: {
   # https://github.com/yesodweb/yesod/issues/1714
   yesod-core = dontCheck super.yesod-core;
 
+  # DerivingVia is not allowed in safe Haskell
+  # https://github.com/strake/util.hs/issues/1
+  util = appendConfigureFlags [
+    "--ghc-option=-fno-safe-haskell"
+    "--haddock-option=--optghc=-fno-safe-haskell"
+  ] super.util;
+  category = appendConfigureFlags [
+    "--ghc-option=-fno-safe-haskell"
+    "--haddock-option=--optghc=-fno-safe-haskell"
+  ] super.category;
+  alg = appendConfigureFlags [
+    "--ghc-option=-fno-safe-haskell"
+    "--haddock-option=--optghc=-fno-safe-haskell"
+  ] super.alg;
+
   # Break out of overspecified constraint on QuickCheck.
   algebraic-graphs = dontCheck super.algebraic-graphs;
   attoparsec = doJailbreak super.attoparsec;      # https://github.com/haskell/attoparsec/pull/168