about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorKosyrev Serge <serge.kosyrev@iohk.io>2018-03-12 02:23:23 +0300
committerKosyrev Serge <serge.kosyrev@iohk.io>2018-03-12 03:03:30 +0300
commit662bc073b2579e29caad1d40aaed7b0b91f91888 (patch)
tree5b3b49a65f433e5fae7eec07cbcd22806df51c8c /pkgs/development
parent8f72b8a5c0c1e16b8538642da9d0b6f9148e8b26 (diff)
downloadnixlib-662bc073b2579e29caad1d40aaed7b0b91f91888.tar
nixlib-662bc073b2579e29caad1d40aaed7b0b91f91888.tar.gz
nixlib-662bc073b2579e29caad1d40aaed7b0b91f91888.tar.bz2
nixlib-662bc073b2579e29caad1d40aaed7b0b91f91888.tar.lz
nixlib-662bc073b2579e29caad1d40aaed7b0b91f91888.tar.xz
nixlib-662bc073b2579e29caad1d40aaed7b0b91f91888.tar.zst
nixlib-662bc073b2579e29caad1d40aaed7b0b91f91888.zip
ghc841: cabal2nix fixed upstream
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix25
1 files changed, 18 insertions, 7 deletions
diff --git a/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix b/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix
index 1582dfe86120..d4c884a5f613 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix
@@ -194,6 +194,24 @@ self: super: {
     };
   });
 
+  ## Upstreamed, awaiting a Hackage release
+  cabal2nix = (overrideCabal super.cabal2nix (drv: {
+    ##     Ambiguous occurrence ‘<>’
+    ##     It could refer to either ‘Prelude.<>’,
+    ##                              imported from ‘Prelude’ at src/Distribution/Nixpkgs/Haskell/Derivation.hs:6:8-46
+    src = pkgs.fetchFromGitHub {
+      owner  = "nixos";
+      repo   = "cabal2nix";
+      rev    = "32974fcc3d9b485bd35167d9ae90941a5b3d06df";
+      sha256 = "1racp49z5922rvrc62clslzdkxh4axj2i0k83w5y6w5chl83abyd";
+    };
+  })).override {
+    ##     • No instance for (Semigroup (List a))
+    ##         arising from the 'deriving' clause of a data type declaration
+    ##       Possible fix:
+    hpack = self.hpack;
+  };
+
   haskell-gi = overrideCabal super.haskell-gi (drv: {
     ## Setup: Encountered missing dependencies:
     ## haskell-gi-base ==0.20.*
@@ -558,13 +576,6 @@ self: super: {
     ];
   });
 
-  cabal2nix = super.cabal2nix.override {
-    ##     • No instance for (Semigroup (List a))
-    ##         arising from the 'deriving' clause of a data type declaration
-    ##       Possible fix:
-    hpack = self.hpack;
-  };
-
   deepseq-generics = overrideCabal super.deepseq-generics (drv: {
     ## Setup: Encountered missing dependencies:
     ## base >=4.5 && <4.11