about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorBen Darwin <bcdarwin@gmail.com>2020-02-26 13:01:03 -0500
committerBen Darwin <bcdarwin@gmail.com>2020-02-26 13:19:28 -0500
commit65461ea1f27ac93e31544f9fae7b481ddd7e3474 (patch)
treec2c15038c82d0e1dbfacb467b5242547c8c0214b /pkgs/development
parent41909e8017e06009ab00309bae50813f7b6c8948 (diff)
downloadnixlib-65461ea1f27ac93e31544f9fae7b481ddd7e3474.tar
nixlib-65461ea1f27ac93e31544f9fae7b481ddd7e3474.tar.gz
nixlib-65461ea1f27ac93e31544f9fae7b481ddd7e3474.tar.bz2
nixlib-65461ea1f27ac93e31544f9fae7b481ddd7e3474.tar.lz
nixlib-65461ea1f27ac93e31544f9fae7b481ddd7e3474.tar.xz
nixlib-65461ea1f27ac93e31544f9fae7b481ddd7e3474.tar.zst
nixlib-65461ea1f27ac93e31544f9fae7b481ddd7e3474.zip
python3Packages.nitime: init at 0.8.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/nitime/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/nitime/default.nix b/pkgs/development/python-modules/nitime/default.nix
new file mode 100644
index 000000000000..b61c3d92bc9f
--- /dev/null
+++ b/pkgs/development/python-modules/nitime/default.nix
@@ -0,0 +1,36 @@
+{ lib
+, buildPythonPackage
+, python
+, fetchPypi
+, pytest
+, cython
+, numpy
+, scipy
+, matplotlib
+, networkx
+, nibabel
+}:
+
+buildPythonPackage rec {
+  pname = "nitime";
+  version = "0.8.1";
+  disabled = python.pythonVersion != "3.7";  # gcc error when running Cython with Python 3.8
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0hb3x5196z2zaawb8s7lhja0vd3n983ncaynqfl9qg315x9ax7i6";
+  };
+
+  checkInputs = [ pytest ];
+  buildInputs = [ cython ];
+  propagatedBuildInputs = [ numpy scipy matplotlib networkx nibabel ];
+
+  checkPhase = "pytest nitime/tests";
+
+  meta = with lib; {
+    homepage = https://nipy.org/nitime;
+    description = "Algorithms and containers for time-series analysis in time and spectral domains";
+    license = licenses.bsd3;
+    maintainers = [ maintainers.bcdarwin ];
+  };
+}