about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2017-10-29 15:45:15 +0100
committerBjørn Forsman <bjorn.forsman@gmail.com>2017-10-29 22:35:15 +0100
commit628e1b9b4ee59ba992af37c8d8786e1957d07849 (patch)
treea34e5d31426c679c2d259a3eb547e7e4fd3a7306 /pkgs/development
parentfb3973a43e5475c63463fc30fbdbf3e3cecf7c68 (diff)
downloadnixlib-628e1b9b4ee59ba992af37c8d8786e1957d07849.tar
nixlib-628e1b9b4ee59ba992af37c8d8786e1957d07849.tar.gz
nixlib-628e1b9b4ee59ba992af37c8d8786e1957d07849.tar.bz2
nixlib-628e1b9b4ee59ba992af37c8d8786e1957d07849.tar.lz
nixlib-628e1b9b4ee59ba992af37c8d8786e1957d07849.tar.xz
nixlib-628e1b9b4ee59ba992af37c8d8786e1957d07849.tar.zst
nixlib-628e1b9b4ee59ba992af37c8d8786e1957d07849.zip
pythonPackages.seqdiag: move to python-modules/
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/seqdiag/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/seqdiag/default.nix b/pkgs/development/python-modules/seqdiag/default.nix
new file mode 100644
index 000000000000..98a81873a718
--- /dev/null
+++ b/pkgs/development/python-modules/seqdiag/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchurl, buildPythonPackage, pep8, nose, unittest2, docutils
+, blockdiag
+}:
+
+buildPythonPackage rec {
+  name = "seqdiag-0.9.4";
+
+  src = fetchurl {
+    url = "mirror://pypi/s/seqdiag/${name}.tar.gz";
+    sha256 = "1qa7d0m1wahvmrj95rxkb6128cbwd4w3gy8gbzncls66h46bifiz";
+  };
+
+  buildInputs = [ pep8 nose unittest2 docutils ];
+
+  propagatedBuildInputs = [ blockdiag ];
+
+  # Tests fail:
+  #   ...
+  #   ERROR: Failure: OSError ([Errno 2] No such file or directory: '/tmp/nix-build-python2.7-seqdiag-0.9.0.drv-0/seqdiag-0.9.0/src/seqdiag/tests/diagrams/')
+  doCheck = false;
+
+  meta = with stdenv.lib; {
+    description = "Generate sequence-diagram image from spec-text file (similar to Graphviz)";
+    homepage = http://blockdiag.com/;
+    license = licenses.asl20;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ bjornfor ];
+  };
+}