about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-04 15:11:12 +0100
committermakefu <github@syntax-fehler.de>2017-12-05 13:31:55 +0100
commit623f9c15e09533cce63ebf5a29ea59d76848bfe7 (patch)
tree57d15432e47135ae660c5d59edbd6fe16fa36e2b /pkgs/development
parent8002a3b760fb843b47e062b02802a3fdebaa9412 (diff)
downloadnixlib-623f9c15e09533cce63ebf5a29ea59d76848bfe7.tar
nixlib-623f9c15e09533cce63ebf5a29ea59d76848bfe7.tar.gz
nixlib-623f9c15e09533cce63ebf5a29ea59d76848bfe7.tar.bz2
nixlib-623f9c15e09533cce63ebf5a29ea59d76848bfe7.tar.lz
nixlib-623f9c15e09533cce63ebf5a29ea59d76848bfe7.tar.xz
nixlib-623f9c15e09533cce63ebf5a29ea59d76848bfe7.tar.zst
nixlib-623f9c15e09533cce63ebf5a29ea59d76848bfe7.zip
devpi-server: init at 4.3.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/devpi-server/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/development/tools/devpi-server/default.nix b/pkgs/development/tools/devpi-server/default.nix
new file mode 100644
index 000000000000..275e411fc8d7
--- /dev/null
+++ b/pkgs/development/tools/devpi-server/default.nix
@@ -0,0 +1,27 @@
+ { stdenv, pythonPackages, glibcLocales, nginx }:
+
+pythonPackages.buildPythonApplication rec {
+  name = "${pname}-${version}";
+  pname = "devpi-server";
+  version = "4.3.1";
+
+  src = pythonPackages.fetchPypi {
+    inherit pname version;
+    sha256 = "0x6ks2sbpknznxaqlh0gf5hcvhkmgixixq2zs91wgfqxk4vi4s6n";
+  };
+
+  propagatedBuildInputs = with pythonPackages;
+    [ devpi-common execnet itsdangerous pluggy waitress pyramid passlib ];
+  checkInputs = with pythonPackages; [ nginx webtest pytest beautifulsoup4 pytest-timeout pytest-catchlog mock pyyaml ];
+  checkPhase = ''
+    cd test_devpi_server/
+    PATH=$PATH:$out/bin pytest --slow -rfsxX
+  '';
+
+  meta = with stdenv.lib;{
+    homepage = http://doc.devpi.net;
+    description = "Github-style pypi index server and packaging meta tool";
+    license = licenses.mit;
+    maintainers = with maintainers; [ makefu ];
+  };
+}