about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJonathan Ringer <jonringer117@gmail.com>2020-04-22 16:02:15 -0700
committerJon <jonringer@users.noreply.github.com>2020-05-01 18:21:02 -0700
commit5a89480b814421ba75c32678aed3beb7a974ef46 (patch)
tree4b399eab78faad17bb6399250352188c070ddc05 /pkgs/development
parentd17be33ecb28136907f180a9722a74e095bc5104 (diff)
downloadnixlib-5a89480b814421ba75c32678aed3beb7a974ef46.tar
nixlib-5a89480b814421ba75c32678aed3beb7a974ef46.tar.gz
nixlib-5a89480b814421ba75c32678aed3beb7a974ef46.tar.bz2
nixlib-5a89480b814421ba75c32678aed3beb7a974ef46.tar.lz
nixlib-5a89480b814421ba75c32678aed3beb7a974ef46.tar.xz
nixlib-5a89480b814421ba75c32678aed3beb7a974ef46.tar.zst
nixlib-5a89480b814421ba75c32678aed3beb7a974ef46.zip
python3Packages.azure-mgmt-core: init at 1.0.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/azure-mgmt-core/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/azure-mgmt-core/default.nix b/pkgs/development/python-modules/azure-mgmt-core/default.nix
new file mode 100644
index 000000000000..54b48427475c
--- /dev/null
+++ b/pkgs/development/python-modules/azure-mgmt-core/default.nix
@@ -0,0 +1,36 @@
+{ pkgs
+, buildPythonPackage
+, fetchPypi
+, python
+, azure-core
+, isPy3k
+}:
+
+buildPythonPackage rec {
+  version = "1.0.0";
+  pname = "azure-mgmt-core";
+
+  src = fetchPypi {
+    inherit pname version;
+    extension = "zip";
+    sha256 = "0pm565v05480f672l0n8z2sg6zk6iqyi91n0dhscibhdl54sy3si";
+  };
+
+  propagatedBuildInputs = [
+    azure-core
+  ];
+
+  pythonNamespaces = "azure.mgmt";
+
+  # not included
+  doCheck = false;
+
+  pythonImportsCheck = [ "azure.mgmt.core" "azure.core" ];
+
+  meta = with pkgs.lib; {
+    description = "Microsoft Azure Management Core Library for Python";
+    homepage = "https://github.com/Azure/azure-sdk-for-python";
+    license = licenses.mit;
+    maintainers = with maintainers; [ jonringer ];
+  };
+}