about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorWilli Butz <wbutz@cyberfnord.de>2017-03-25 15:54:24 +0100
committerTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2017-03-25 17:04:55 +0200
commit55d21cad95cf325e42c0919d1ed8a290d9207f4d (patch)
tree4a2678e04e4f2a5721a9691695a67722020320a0 /pkgs/development
parent5c841654d837e71da08da87d276197c2cba6c144 (diff)
downloadnixlib-55d21cad95cf325e42c0919d1ed8a290d9207f4d.tar
nixlib-55d21cad95cf325e42c0919d1ed8a290d9207f4d.tar.gz
nixlib-55d21cad95cf325e42c0919d1ed8a290d9207f4d.tar.bz2
nixlib-55d21cad95cf325e42c0919d1ed8a290d9207f4d.tar.lz
nixlib-55d21cad95cf325e42c0919d1ed8a290d9207f4d.tar.xz
nixlib-55d21cad95cf325e42c0919d1ed8a290d9207f4d.tar.zst
nixlib-55d21cad95cf325e42c0919d1ed8a290d9207f4d.zip
manticore: fix build, remove builder.sh (see #23253)
Diffstat (limited to 'pkgs/development')
-rwxr-xr-xpkgs/development/compilers/manticore/builder.sh24
-rw-r--r--pkgs/development/compilers/manticore/default.nix29
2 files changed, 22 insertions, 31 deletions
diff --git a/pkgs/development/compilers/manticore/builder.sh b/pkgs/development/compilers/manticore/builder.sh
deleted file mode 100755
index ad72f50a1b31..000000000000
--- a/pkgs/development/compilers/manticore/builder.sh
+++ /dev/null
@@ -1,24 +0,0 @@
-#!@shell@
-
-source $stdenv/setup
-echo "Building Manticore research compiler."
-set -xe
-
-PATH=$smlnj/bin:$PATH
-
-mkdir -p $out/bin
-
-# Manticore seems to use the MLB files from the build tree,
-# so for now we copy the whole build tree into the store:
-cd $out/
-tar xf $src
-mv manticore* repo_checkout
-cd repo_checkout/
-# TODO: At the very least, this could probably be cut down to a subset
-# of the repo.
-
-${autoconf}/bin/autoheader -Iconfig
-${autoconf}/bin/autoconf -Iconfig
-./configure --prefix=$out
-make build -j
-make install
diff --git a/pkgs/development/compilers/manticore/default.nix b/pkgs/development/compilers/manticore/default.nix
index 7e8312549da9..d068d744f203 100644
--- a/pkgs/development/compilers/manticore/default.nix
+++ b/pkgs/development/compilers/manticore/default.nix
@@ -1,14 +1,29 @@
-{ stdenv, fetchurl, coreutils, autoconf, automake, smlnj }:
+{ stdenv, fetchFromGitHub, coreutils, autoreconfHook, smlnj }:
 
-stdenv.mkDerivation rec {
+let
+    rev = "592a5714595b4448b646a7d49df04c285668c2f8";
+in stdenv.mkDerivation rec {
   name = "manticore-${version}";
   version = "2014.08.18";
-  builder = ./builder.sh;
-  src = fetchurl {
-    url = https://github.com/rrnewton/manticore_temp_mirror/archive/snapshot-20140818.tar.gz; 
-    sha256 = "1x52xpj5gbcpqjqm6aw6ssn901f353zypj3d5scm8i3ad777y29d";
+ 
+  src = fetchFromGitHub {
+    owner = "rrnewton";
+    repo = "manticore_temp_mirror";
+    sha256 = "1snwlm9a31wfgvzb80y7r7yvc6n0k0bi675lqwzll95as7cdswwi";
+    inherit rev;
   };
-  inherit stdenv coreutils autoconf automake smlnj;
+
+  enableParallelBuilding = false;
+ 
+  nativeBuildInputs = [ autoreconfHook ];
+  
+  buildInputs = [ coreutils smlnj ];
+
+  autoreconfFlags = "-Iconfig -vfi";
+
+  postPatch = "patchShebangs .";
+
+  preInstall = "mkdir -p $out/bin";
 
   meta = {
     description = "A parallel, pure variant of Standard ML";