about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorKeshav Kini <keshav.kini@gmail.com>2020-06-14 14:01:44 -0700
committerKeshav Kini <keshav.kini@gmail.com>2020-06-14 18:38:16 -0700
commit557f56d46568d309f31a735fa16075f3de457f2b (patch)
tree55cf5b8d3dfd8b637e28f317bb0dec199ac16a6d /pkgs/development
parentc2f945b43a18252d0d107a150d190161afe51063 (diff)
downloadnixlib-557f56d46568d309f31a735fa16075f3de457f2b.tar
nixlib-557f56d46568d309f31a735fa16075f3de457f2b.tar.gz
nixlib-557f56d46568d309f31a735fa16075f3de457f2b.tar.bz2
nixlib-557f56d46568d309f31a735fa16075f3de457f2b.tar.lz
nixlib-557f56d46568d309f31a735fa16075f3de457f2b.tar.xz
nixlib-557f56d46568d309f31a735fa16075f3de457f2b.tar.zst
nixlib-557f56d46568d309f31a735fa16075f3de457f2b.zip
liblastfm: 1.1.0 -> liblastfm-unstable 2019-08-23
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/liblastfm/default.nix31
1 files changed, 14 insertions, 17 deletions
diff --git a/pkgs/development/libraries/liblastfm/default.nix b/pkgs/development/libraries/liblastfm/default.nix
index 762e707528a6..830e125685e7 100644
--- a/pkgs/development/libraries/liblastfm/default.nix
+++ b/pkgs/development/libraries/liblastfm/default.nix
@@ -1,27 +1,24 @@
-{ stdenv, fetchurl, pkgconfig, which, cmake
+{ stdenv, fetchFromGitHub, fetchpatch, pkgconfig, which, cmake
 , fftwSinglePrec, libsamplerate, qtbase
 , darwin }:
 
-let version = "1.1.0"; in
-
 stdenv.mkDerivation rec {
-  pname = "liblastfm";
-  inherit version;
+  pname = "liblastfm-unstable";
+  version = "2019-08-23";
 
-  # Upstream does not package git tags as tarballs. Get tarball from github.
-  src = fetchurl {
-    url = "https://github.com/lastfm/liblastfm/tarball/${version}";
-    name = "${pname}-${version}.tar.gz";
-    sha256 = "1j34xc30vg7sfszm2jx9mlz9hy7p1l929fka9wnfcpbib8gfi43x";
+  src = fetchFromGitHub {
+    owner = "lastfm";
+    repo = "liblastfm";
+    rev = "2ce2bfe1879227af8ffafddb82b218faff813db9";
+    sha256 = "1crih9xxf3rb109aqw12bjqv47z28lvlk2dpvyym5shf82nz6yd0";
   };
 
-  postPatch = ''
-    substituteInPlace CMakeLists.txt \
-      --replace 'find_package(Qt5Core QUIET)' \
-                'find_package(Qt5 REQUIRED COMPONENTS Core Network Sql Test Xml)'
-  '';
+  patches = [(fetchpatch {
+    url = "https://github.com/lastfm/liblastfm/commit/9c5d072b55f2863310e40291677e6397e9cbc3c2.patch";
+    name = "0001-Remove-deprecated-staging-server-and-fix-test-for-QT5-at-Ubuntu-19.10.patch";
+    sha256 = "04r14prydxshjgfws3pjajjmp2msszhjjs1mjh8s66yg29vq620l";
+  })];
 
-  prefixKey = "--prefix ";
   nativeBuildInputs = [ pkgconfig which cmake ];
   buildInputs = [ fftwSinglePrec libsamplerate qtbase ]
     ++ stdenv.lib.optional stdenv.isDarwin darwin.apple_sdk.frameworks.SystemConfiguration;
@@ -31,7 +28,7 @@ stdenv.mkDerivation rec {
     repositories.git = "git://github.com/lastfm/liblastfm.git";
     description = "Official LastFM library";
     platforms = platforms.unix;
-    maintainers =  [ maintainers.phreedom ];
+    maintainers = [ maintainers.phreedom ];
     license = licenses.gpl3;
   };
 }