about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2018-03-13 13:29:17 +0100
committerGitHub <noreply@github.com>2018-03-13 13:29:17 +0100
commit54ade273e7a677ec35e501174d86d253d9d8dede (patch)
tree0e70a3fd7cfd8d0e501f067e6a8d6e4abef173bb /pkgs/development
parent2aa8a208b0e37dcbdccc6cbd25b0769ea91628f6 (diff)
parent46f9e1063618679e8370d22ffe236f59ae99cb65 (diff)
downloadnixlib-54ade273e7a677ec35e501174d86d253d9d8dede.tar
nixlib-54ade273e7a677ec35e501174d86d253d9d8dede.tar.gz
nixlib-54ade273e7a677ec35e501174d86d253d9d8dede.tar.bz2
nixlib-54ade273e7a677ec35e501174d86d253d9d8dede.tar.lz
nixlib-54ade273e7a677ec35e501174d86d253d9d8dede.tar.xz
nixlib-54ade273e7a677ec35e501174d86d253d9d8dede.tar.zst
nixlib-54ade273e7a677ec35e501174d86d253d9d8dede.zip
Merge pull request #36526 from idontgetoutmuch/master
Add sundials
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/sundials/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/development/libraries/sundials/default.nix b/pkgs/development/libraries/sundials/default.nix
new file mode 100644
index 000000000000..41f7267fdca9
--- /dev/null
+++ b/pkgs/development/libraries/sundials/default.nix
@@ -0,0 +1,28 @@
+{ cmake, fetchurl, python, stdenv }:
+
+stdenv.mkDerivation rec {
+
+  pname = "sundials";
+  version = "3.1.0";
+  name = "${pname}-${version}";
+
+  src = fetchurl {
+  url = "https://computation.llnl.gov/projects/${pname}/download/${pname}-${version}.tar.gz";
+  sha256 = "0fnlrpj6qjamxahd70r4vsgv85kxbgh93gxqk5xzf9ln6a7jzm8q";
+  };
+
+  preConfigure = ''
+    export cmakeFlags="-DCMAKE_INSTALL_PREFIX=$out -DEXAMPLES_INSTALL_PATH=$out/share/examples $cmakeFlags"
+  '';
+  
+  buildInputs = [ cmake python ];
+
+  meta = with stdenv.lib; {
+    description = "Suite of nonlinear differential/algebraic equation solvers";
+    homepage    = https://computation.llnl.gov/casc/sundials/main.html;
+    platforms   = platforms.all;
+    maintainers = [ maintainers.idontgetoutmuch ];
+    license     = licenses.bsd3;
+  };
+
+}