about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDrew Risinger <drewrisinger@users.noreply.github.com>2020-04-02 11:42:33 -0400
committerDrew Risinger <drewrisinger@users.noreply.github.com>2020-04-02 12:07:21 -0400
commit53b803ed95b6d24fb71f73122cdf5a66676e994b (patch)
treeed03aaf53d6de10c4101f52410dcd5dd30ddf870 /pkgs/development
parent49859351eac79b16dce4b21c6ebb824314fa5c2d (diff)
downloadnixlib-53b803ed95b6d24fb71f73122cdf5a66676e994b.tar
nixlib-53b803ed95b6d24fb71f73122cdf5a66676e994b.tar.gz
nixlib-53b803ed95b6d24fb71f73122cdf5a66676e994b.tar.bz2
nixlib-53b803ed95b6d24fb71f73122cdf5a66676e994b.tar.lz
nixlib-53b803ed95b6d24fb71f73122cdf5a66676e994b.tar.xz
nixlib-53b803ed95b6d24fb71f73122cdf5a66676e994b.tar.zst
nixlib-53b803ed95b6d24fb71f73122cdf5a66676e994b.zip
pythonPackages.cvxpy: explicit numpy/scipy
Make numpy/scipy dependencies explicit, based on conda install
instructions for cvxpy.
Slight formatting fix.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/cvxpy/default.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/pkgs/development/python-modules/cvxpy/default.nix b/pkgs/development/python-modules/cvxpy/default.nix
index 2a77f45217a0..ccb51b059d6a 100644
--- a/pkgs/development/python-modules/cvxpy/default.nix
+++ b/pkgs/development/python-modules/cvxpy/default.nix
@@ -29,7 +29,9 @@ buildPythonPackage rec {
     cvxopt
     ecos
     multiprocess
+    numpy
     osqp
+    scipy
     scs
     six
   ];
@@ -39,11 +41,11 @@ buildPythonPackage rec {
     nosetests
   '';
 
-  meta = {
+  meta = with lib; {
     description = "A domain-specific language for modeling convex optimization problems in Python.";
     homepage = "https://www.cvxpy.org/";
     downloadPage = "https://github.com/cvxgrp/cvxpy/";
-    license = lib.licenses.asl20;
-    maintainers = with lib.maintainers; [ drewrisinger ];
+    license = licenses.asl20;
+    maintainers = with maintainers; [ drewrisinger ];
   };
 }