about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorIvan Sorokin <vanyacpp@gmail.com>2016-11-12 14:32:04 +0300
committerIvan Sorokin <vanyacpp@gmail.com>2016-11-12 14:34:13 +0300
commit52ccc27c1e8c41e6a59dc186eef2adafba1963c7 (patch)
treecf5a3a1dda32a5458dd40bc22706225c434b6f00 /pkgs/development
parent1c3b496f0d095790b678471aeb3a67708c6cc0a7 (diff)
downloadnixlib-52ccc27c1e8c41e6a59dc186eef2adafba1963c7.tar
nixlib-52ccc27c1e8c41e6a59dc186eef2adafba1963c7.tar.gz
nixlib-52ccc27c1e8c41e6a59dc186eef2adafba1963c7.tar.bz2
nixlib-52ccc27c1e8c41e6a59dc186eef2adafba1963c7.tar.lz
nixlib-52ccc27c1e8c41e6a59dc186eef2adafba1963c7.tar.xz
nixlib-52ccc27c1e8c41e6a59dc186eef2adafba1963c7.tar.zst
nixlib-52ccc27c1e8c41e6a59dc186eef2adafba1963c7.zip
fix autobuild compilation
Currently autobuild failed to build in both master and release-16.03. The
error message is

   mv: cannot stat '/nix/store/a4jzlkrhd4b4nr5760caj3rrjxhyg4z3-autobuild-5.3/bin/abput-sourceforge': No such file or directory
   builder for ‘/nix/store/l19vywq8zvbarswby5h7vl4iq1c1pvq7-autobuild-5.3.drv’ failed with exit code 1

It happens in post install script

   postInstall = ''
     wrapProgram $out/bin/ab{put,build}-sourceforge \
       --prefix PATH ":" "${stdenv.lib.makeBinPath [ openssh rsync ]}"
   '';

The problem is that in autobuild 5.0 the ab{put,build}-sourceforge were removed

   * Version 5.0 (released 2008-11-25)
   ...
   ** abput, abput-sourceforge, abput-testdrive: Remove.
   ** abbuild, abbuild-sourceforge: Remove.
   Both the SourceForge and TestDrive systems have been shutdown.  The
   scripts were of questionable value anyway.

Possibly the bug was introduced in commit
8c4fcc87f8320004e924f53bbaee29ae3b7b4692: autobuild: 3.5 -> 5.3.

As the package doesn't contain these programs there is no need in wrapping
them. This commit just remove the postInstall section of corresponding
package.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/misc/autobuild/default.nix5
1 files changed, 0 insertions, 5 deletions
diff --git a/pkgs/development/tools/misc/autobuild/default.nix b/pkgs/development/tools/misc/autobuild/default.nix
index a7d6c42e6af2..6919b03d47c1 100644
--- a/pkgs/development/tools/misc/autobuild/default.nix
+++ b/pkgs/development/tools/misc/autobuild/default.nix
@@ -12,11 +12,6 @@ stdenv.mkDerivation rec {
 
   doCheck = true;
 
-  postInstall = ''
-    wrapProgram $out/bin/ab{put,build}-sourceforge \
-      --prefix PATH ":" "${stdenv.lib.makeBinPath [ openssh rsync ]}"
-  '';
-
   meta = {
     description = "Continuous integration tool";