about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-08-11 14:16:34 -0400
committerGitHub <noreply@github.com>2019-08-11 14:16:34 -0400
commit51816f0d405e8e6310265f2bf09adb811e0f5b76 (patch)
tree526b3b3ba16c4eee7997278b9dc4ad022f55a602 /pkgs/development
parent4ff9a48398f1e3ebf8e6ea315b326f66bfd6ae0e (diff)
parent4673896662e19a9341771cfe0d863490b24bcacd (diff)
downloadnixlib-51816f0d405e8e6310265f2bf09adb811e0f5b76.tar
nixlib-51816f0d405e8e6310265f2bf09adb811e0f5b76.tar.gz
nixlib-51816f0d405e8e6310265f2bf09adb811e0f5b76.tar.bz2
nixlib-51816f0d405e8e6310265f2bf09adb811e0f5b76.tar.lz
nixlib-51816f0d405e8e6310265f2bf09adb811e0f5b76.tar.xz
nixlib-51816f0d405e8e6310265f2bf09adb811e0f5b76.tar.zst
nixlib-51816f0d405e8e6310265f2bf09adb811e0f5b76.zip
Merge pull request #66249 from virusdave/dnicponski/scratch/unison_language
unison-ucm: init at 1.0.M1c alpha
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/unison/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/development/compilers/unison/default.nix b/pkgs/development/compilers/unison/default.nix
new file mode 100644
index 000000000000..3bdf234f9159
--- /dev/null
+++ b/pkgs/development/compilers/unison/default.nix
@@ -0,0 +1,41 @@
+{ stdenv, fetchurl, autoPatchelfHook
+, ncurses5, zlib, gmp
+}:
+
+stdenv.mkDerivation rec {
+  pname = "unison-code-manager";
+  milestone_id = "M1c";
+  version = "1.0.${milestone_id}-alpha";
+
+  src = if (stdenv.isDarwin) then
+    fetchurl {
+      url = "https://github.com/unisonweb/unison/releases/download/release/${milestone_id}/unison-osx.tar.gz";
+      sha256 = "03q02r7qc7ybqz16kmpk2d8l9vx28kaj9x59mlxzi8a4mr0j3vzb";
+    }
+  else
+    fetchurl {
+      url = "https://github.com/unisonweb/unison/releases/download/release/${milestone_id}/unison-linux64.tar.gz";
+      sha256 = "1iwynqnp1i39pyq9wc01x7y22y1qa0rrjlx40jjdgnj23y1r6jk4";
+    };
+
+  # The tarball is just the prebuilt binary, in the archive root.
+  sourceRoot = ".";
+  dontBuild = true;
+  dontConfigure = true;
+
+  nativeBuildInputs = stdenv.lib.optional (!stdenv.isDarwin) autoPatchelfHook;
+  buildInputs = stdenv.lib.optionals (!stdenv.isDarwin) [ ncurses5 zlib gmp ];
+
+  installPhase = ''
+    mkdir -p $out/bin
+    mv ucm $out/bin
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Modern, statically-typed purely functional language";
+    homepage = http://unisonweb.org/posts/;
+    license = licenses.free;
+    maintainers = [ maintainers.virusdave ];
+    platforms = [ "x86_64-darwin" "x86_64-linux" ];
+  };
+}