about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-09-24 11:32:16 +0100
committerGitHub <noreply@github.com>2017-09-24 11:32:16 +0100
commit50946a790e7b3290074eb39aa2d47b6359592342 (patch)
tree06808a0144a63d7efe617387ba31d0c0305a6e96 /pkgs/development
parent0e71e03583b10182cbd926c8b60acbbff4e4753d (diff)
parent6786ad7db6bacc9b5a1025abdfde80ab781fc826 (diff)
downloadnixlib-50946a790e7b3290074eb39aa2d47b6359592342.tar
nixlib-50946a790e7b3290074eb39aa2d47b6359592342.tar.gz
nixlib-50946a790e7b3290074eb39aa2d47b6359592342.tar.bz2
nixlib-50946a790e7b3290074eb39aa2d47b6359592342.tar.lz
nixlib-50946a790e7b3290074eb39aa2d47b6359592342.tar.xz
nixlib-50946a790e7b3290074eb39aa2d47b6359592342.tar.zst
nixlib-50946a790e7b3290074eb39aa2d47b6359592342.zip
Merge pull request #29727 from vyp/init/guile-fibers
guile-fibers: init at 1.0.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/guile-modules/guile-fibers/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/development/guile-modules/guile-fibers/default.nix b/pkgs/development/guile-modules/guile-fibers/default.nix
new file mode 100644
index 000000000000..5f82a93c513a
--- /dev/null
+++ b/pkgs/development/guile-modules/guile-fibers/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, guile, texinfo }:
+
+let
+  version = "1.0.0";
+  name = "guile-fibers-${version}";
+in stdenv.mkDerivation {
+  inherit name;
+
+  src = fetchFromGitHub {
+    owner = "wingo";
+    repo = "fibers";
+    rev = "v${version}";
+    sha256 = "1r47m1m112kxf23xny99f0qkqsk6626iyc5jp7vzndfiyp5yskwi";
+  };
+
+  nativeBuildInputs = [ autoreconfHook pkgconfig ];
+  buildInputs = [ guile texinfo ];
+
+  autoreconfPhase = "./autogen.sh";
+
+  meta = with stdenv.lib; {
+    description = "Concurrent ML-like concurrency for Guile";
+    homepage = https://github.com/wingo/fibers;
+    license = licenses.lgpl3Plus;
+    maintainers = with maintainers; [ vyp ];
+    platforms = platforms.all;
+  };
+}