about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2019-05-12 15:22:01 -0400
committerGitHub <noreply@github.com>2019-05-12 15:22:01 -0400
commit4fb6ccbe615775e3b6aa8408bb976449437542a7 (patch)
tree7f147e3eb5ac44290c56b4e5a03ae743455d1498 /pkgs/development
parentab1f3774805bc6314ef5cab201979f2e6dec697e (diff)
parent81a9b46ee8d8df17839bdccfef4c4f58864f4586 (diff)
downloadnixlib-4fb6ccbe615775e3b6aa8408bb976449437542a7.tar
nixlib-4fb6ccbe615775e3b6aa8408bb976449437542a7.tar.gz
nixlib-4fb6ccbe615775e3b6aa8408bb976449437542a7.tar.bz2
nixlib-4fb6ccbe615775e3b6aa8408bb976449437542a7.tar.lz
nixlib-4fb6ccbe615775e3b6aa8408bb976449437542a7.tar.xz
nixlib-4fb6ccbe615775e3b6aa8408bb976449437542a7.tar.zst
nixlib-4fb6ccbe615775e3b6aa8408bb976449437542a7.zip
Merge pull request #61112 from matthewbauer/fix-bazel-llvm
bazel: use llvm6 on darwin
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/build-managers/bazel/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/development/tools/build-managers/bazel/default.nix b/pkgs/development/tools/build-managers/bazel/default.nix
index 1e29e4b34f08..e106c6962dc3 100644
--- a/pkgs/development/tools/build-managers/bazel/default.nix
+++ b/pkgs/development/tools/build-managers/bazel/default.nix
@@ -153,7 +153,7 @@ stdenv.mkDerivation rec {
       sed -i -e 's/<.*\*>//g' tools/osx/xcode_locator.m
 
       # don't use system installed Xcode to run clang, use Nix clang instead
-      sed -i -e "s;/usr/bin/xcrun clang;${clang}/bin/clang $NIX_CFLAGS_COMPILE $NIX_LDFLAGS -framework CoreFoundation;g" \
+      sed -i -e "s;/usr/bin/xcrun clang;${stdenv.cc}/bin/clang $NIX_CFLAGS_COMPILE $NIX_LDFLAGS -framework CoreFoundation;g" \
         scripts/bootstrap/compile.sh \
         src/tools/xcode/realpath/BUILD \
         src/tools/xcode/stdredirect/BUILD \
@@ -256,7 +256,7 @@ stdenv.mkDerivation rec {
     makeWrapper
     which
     customBash
-  ] ++ lib.optionals (stdenv.isDarwin) [ cctools clang libcxx CoreFoundation CoreServices Foundation ];
+  ] ++ lib.optionals (stdenv.isDarwin) [ cctools libcxx CoreFoundation CoreServices Foundation ];
 
   # Bazel makes extensive use of symlinks in the WORKSPACE.
   # This causes problems with infinite symlinks if the build output is in the same location as the