about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSimon Chatterjee <code@chatts.net>2020-02-18 11:08:00 +0000
committerPeter Simons <simons@cryp.to>2020-02-28 20:31:23 +0100
commit4f3959790301dea00a3a84086c2875051c63b5e1 (patch)
tree7df8cd013ac9b51c05c65aae36317eecc0b8541b /pkgs/development
parent3d7b19344d8e3c81ac5f23af776f09ec88962099 (diff)
downloadnixlib-4f3959790301dea00a3a84086c2875051c63b5e1.tar
nixlib-4f3959790301dea00a3a84086c2875051c63b5e1.tar.gz
nixlib-4f3959790301dea00a3a84086c2875051c63b5e1.tar.bz2
nixlib-4f3959790301dea00a3a84086c2875051c63b5e1.tar.lz
nixlib-4f3959790301dea00a3a84086c2875051c63b5e1.tar.xz
nixlib-4f3959790301dea00a3a84086c2875051c63b5e1.tar.zst
nixlib-4f3959790301dea00a3a84086c2875051c63b5e1.zip
spago: fix Darwin build
This change gets round a weird permissions error on darwin
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index c1b1c22d5543..813ab160a2cf 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -680,6 +680,11 @@ self: super: builtins.intersectAttrs super {
           # https://github.com/spacchetti/spago/issues/510
           cp ${docsSearchAppJsFile} "$sourceRoot/templates/docs-search-app.js"
           cp ${purescriptDocsSearchFile} "$sourceRoot/templates/purescript-docs-search"
+
+          # For some weird reason, on Darwin, the open(2) call to embed these files
+          # requires write permissions. The easiest resolution is just to permit that
+          # (doesn't cause any harm on other systems).
+          chmod u+w "$sourceRoot/templates/docs-search-app.js" "$sourceRoot/templates/purescript-docs-search"
         '';
       });