about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDaiderd Jordan <daiderd@gmail.com>2019-02-17 12:35:29 +0100
committerGitHub <noreply@github.com>2019-02-17 12:35:29 +0100
commit4c01785170cbec45635aed0a5c3c20a77b206e07 (patch)
tree910b84425f123106c7e2a232a37755e129dfb3c1 /pkgs/development
parent7677ebb575119f3e03876f43188b9c9a4d188911 (diff)
parent34726a8139ecde1b1337d430d49ae57dea6ded8b (diff)
downloadnixlib-4c01785170cbec45635aed0a5c3c20a77b206e07.tar
nixlib-4c01785170cbec45635aed0a5c3c20a77b206e07.tar.gz
nixlib-4c01785170cbec45635aed0a5c3c20a77b206e07.tar.bz2
nixlib-4c01785170cbec45635aed0a5c3c20a77b206e07.tar.lz
nixlib-4c01785170cbec45635aed0a5c3c20a77b206e07.tar.xz
nixlib-4c01785170cbec45635aed0a5c3c20a77b206e07.tar.zst
nixlib-4c01785170cbec45635aed0a5c3c20a77b206e07.zip
Merge pull request #55777 from LnL7/haskell-conduit-extra
haskellPackages.conduit-extra: fix darwin sandbox build
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index 4391f7b6f46a..e13f87ed6d62 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -151,6 +151,10 @@ self: super: {
   # dontCheck due to https://github.com/haskell/vector/issues/138
   vector = dontCheck (if pkgs.stdenv.isi686 then appendConfigureFlag super.vector "--ghc-options=-msse2" else super.vector);
 
+  conduit-extra = if pkgs.stdenv.isDarwin
+    then super.conduit-extra.overrideAttrs (drv: { __darwinAllowLocalNetworking = true; })
+    else super.conduit-extra;
+
   # Fix Darwin build.
   halive = if pkgs.stdenv.isDarwin
     then addBuildDepend super.halive pkgs.darwin.apple_sdk.frameworks.AppKit