about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2017-07-13 08:38:58 +0200
committerGitHub <noreply@github.com>2017-07-13 08:38:58 +0200
commit4a599a688eefdea36948bc584791c1f3a8b91b77 (patch)
tree018a27201d012ef264194cb33930fc52c13a13d2 /pkgs/development
parent598d79ae7d3d53d4bb4e317cb8f8a035c7151b35 (diff)
parent51edf3bf88e4c1ba7a32ac9bfecfdbf69322bad0 (diff)
downloadnixlib-4a599a688eefdea36948bc584791c1f3a8b91b77.tar
nixlib-4a599a688eefdea36948bc584791c1f3a8b91b77.tar.gz
nixlib-4a599a688eefdea36948bc584791c1f3a8b91b77.tar.bz2
nixlib-4a599a688eefdea36948bc584791c1f3a8b91b77.tar.lz
nixlib-4a599a688eefdea36948bc584791c1f3a8b91b77.tar.xz
nixlib-4a599a688eefdea36948bc584791c1f3a8b91b77.tar.zst
nixlib-4a599a688eefdea36948bc584791c1f3a8b91b77.zip
Merge pull request #27322 from dmjio/patch-4
miso: init at 0.2.0.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-ghcjs.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-ghcjs.nix b/pkgs/development/haskell-modules/configuration-ghcjs.nix
index fd7f15008d26..7efb75c33296 100644
--- a/pkgs/development/haskell-modules/configuration-ghcjs.nix
+++ b/pkgs/development/haskell-modules/configuration-ghcjs.nix
@@ -150,6 +150,17 @@ self: super:
   http2 = addBuildDepends super.http2 [ self.aeson self.aeson-pretty self.hex self.unordered-containers self.vector self.word8 ];
   # ghcjsBoot uses async 2.0.1.6, protolude wants 2.1.*
 
+  # These are the correct dependencies specified when calling `cabal2nix --compiler ghcjs`
+  # By default, the `miso` derivation present in hackage-packages.nix
+  # does not contain dependencies suitable for ghcjs
+  miso = overrideCabal super.miso (drv: {
+      libraryHaskellDepends = with self; [
+        BoundedChan bytestring containers ghcjs-base aeson base
+        http-api-data http-types network-uri scientific servant text
+        transformers unordered-containers vector
+      ];
+    });
+
   pqueue = overrideCabal super.pqueue (drv: {
     postPatch = ''
       sed -i -e '12s|null|Data.PQueue.Internals.null|' Data/PQueue/Internals.hs