about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@mailbox.org>2017-07-20 10:42:58 -0500
committerThomas Tuegel <ttuegel@mailbox.org>2017-07-21 15:45:32 -0500
commit4a0a066f67b204315f8b3fa59e87f2634f26b7e9 (patch)
tree6524e62098fdd9e381d99cec3b29e29b0a2ae0c0 /pkgs/development
parentc25199f6973dff040a3d248a759636f8b981b02d (diff)
downloadnixlib-4a0a066f67b204315f8b3fa59e87f2634f26b7e9.tar
nixlib-4a0a066f67b204315f8b3fa59e87f2634f26b7e9.tar.gz
nixlib-4a0a066f67b204315f8b3fa59e87f2634f26b7e9.tar.bz2
nixlib-4a0a066f67b204315f8b3fa59e87f2634f26b7e9.tar.lz
nixlib-4a0a066f67b204315f8b3fa59e87f2634f26b7e9.tar.xz
nixlib-4a0a066f67b204315f8b3fa59e87f2634f26b7e9.tar.zst
nixlib-4a0a066f67b204315f8b3fa59e87f2634f26b7e9.zip
newt: unset CPP
Commit 093cc00cdd9d8cf31ecce5bc1dd3645c460a1b98 sets the CPP environment
variable by default, confusing the newt Makefile, which expects CPP=gcc for
computing dependencies.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/newt/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/development/libraries/newt/default.nix b/pkgs/development/libraries/newt/default.nix
index 9002d06693e5..e00decca2ffd 100644
--- a/pkgs/development/libraries/newt/default.nix
+++ b/pkgs/development/libraries/newt/default.nix
@@ -16,6 +16,12 @@ stdenv.mkDerivation rec {
 
   NIX_LDFLAGS = "-lncurses";
 
+  preConfigure = ''
+    # If CPP is set explicitly, configure and make will not agree about which
+    # programs to use at different stages.
+    unset CPP
+  '';
+
   crossAttrs = {
     makeFlags = "CROSS_COMPILE=${stdenv.cc.prefix}";
   };