about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2016-03-12 15:41:12 +0100
committerVincent Laporte <Vincent.Laporte@gmail.com>2016-03-14 12:06:18 +0100
commit456d16ff4b01aee5fa9ac52eb215c3ee54a46a02 (patch)
tree6928b9d3b0ad3b65580d03339259b14844d08355 /pkgs/development
parentcdd78ce13381f220d914c2390486fa6c4d367324 (diff)
downloadnixlib-456d16ff4b01aee5fa9ac52eb215c3ee54a46a02.tar
nixlib-456d16ff4b01aee5fa9ac52eb215c3ee54a46a02.tar.gz
nixlib-456d16ff4b01aee5fa9ac52eb215c3ee54a46a02.tar.bz2
nixlib-456d16ff4b01aee5fa9ac52eb215c3ee54a46a02.tar.lz
nixlib-456d16ff4b01aee5fa9ac52eb215c3ee54a46a02.tar.xz
nixlib-456d16ff4b01aee5fa9ac52eb215c3ee54a46a02.tar.zst
nixlib-456d16ff4b01aee5fa9ac52eb215c3ee54a46a02.zip
verasco: init at 1.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/analysis/verasco/default.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/pkgs/development/tools/analysis/verasco/default.nix b/pkgs/development/tools/analysis/verasco/default.nix
new file mode 100644
index 000000000000..9b3ff8e570d6
--- /dev/null
+++ b/pkgs/development/tools/analysis/verasco/default.nix
@@ -0,0 +1,48 @@
+{ stdenv, fetchurl, coq, ocamlPackages
+, tools ? stdenv.cc
+}:
+
+stdenv.mkDerivation rec {
+  name = "verasco-1.3";
+  src = fetchurl {
+    url = "http://compcert.inria.fr/verasco/release/${name}.tgz";
+    sha256 = "0zvljrpwnv443k939zlw1f7ijwx18nhnpr8jl3f01jc5v66hr2k8";
+  };
+
+  buildInputs = [ coq ] ++ (with ocamlPackages; [ ocaml findlib menhir zarith ]);
+
+  preConfigure = ''
+    substituteInPlace ./configure --replace '{toolprefix}gcc' '{toolprefix}cc'
+  '';
+
+  configureFlags = [
+    "-toolprefix ${tools}/bin/"
+    (if stdenv.isDarwin then "ia32-macosx" else "ia32-linux")
+  ];
+
+  prefixKey = "-prefix ";
+
+  enableParallelBuilding = true;
+  buildFlags = "proof extraction ccheck";
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp ccheck $out/bin/
+    ln -s $out/bin/ccheck $out/bin/verasco
+    if [ -e verasco.ini ]
+    then
+      mkdir -p $out/share
+      cp verasco.ini $out/share/
+    fi
+    mkdir -p $out/lib/compcert
+    cp -riv runtime/include $out/lib/compcert
+  '';
+
+  meta = {
+    homepage = http://compcert.inria.fr/verasco/;
+    description = "A static analyzer for the CompCert subset of ISO C 1999";
+    maintainers = with stdenv.lib.maintainers; [ vbgl ];
+    license = stdenv.lib.licenses.unfree;
+    platforms = with stdenv.lib.platforms; darwin ++ linux;
+  };
+}